1996 Saturn SL2 I think my car is done for.

Tiny
ASHLEEB
  • MEMBER
  • 1996 SATURN SL2
Engine Performance problem
1996 Saturn SL2 194000 miles

My car drove perfectly today, I went out and started it to warm it up and went back inside, came out five minutes later and heard a rattling noise, got in my car and I noticed my battery light was on, kind of ignored it and started driving, 30 seconds later, my car starts overheating so I pull over and shut it off, then it was making a loud knocking noise, checked my oil and was pretty low so I let it cool down and went to the gas station 10 seconds away and put a few quarts of oil in it, didn't do anything it got worse on my way home, eventually my windshield wipers didn't work and my tempature gauge when right to cold ( after being past the half way mark) and my mph dropped to 0 even though my car was still going, I made it home and my car was smoking. So I turned it off. Maybe 10 min later I started my car just to see if it would start and it did and my windshield wipers started working so I don't know soounds to me I blew my engine! Please help
Do you
have the same problem?
Yes
No
Tuesday, December 8th, 2009 AT 9:55 PM

14 Replies

Tiny
SATURNTECH9
  • EXPERT
How many quarts low was ur oil?Also check ur belt tenisor if it fails ur battery light will come on and ur water pump won't spin causing ur car to overheat won't take long to over heat. Also would explain ur wipers to be inop and gauges to go wild. Let me know what u find.
Louie
Was this
answer
helpful?
Yes
No
Tuesday, December 8th, 2009 AT 10:28 PM
Tiny
ASHLEEB
  • MEMBER
I think I may have found the problem when I opened up my hood this morning. My serpantine belt was completely loose. Hopefully the damage isn't already done to my car.I drove it for about 3-4 miles. Crossing my fingers!
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 10:11 AM
Tiny
SATURNTECH9
  • EXPERT
Thats what I was guess ur belt tenisor I asked u to check it. Let me know what u find.
Louie
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 2:26 PM
Tiny
ASHLEEB
  • MEMBER
I don't know anything about cars, but the pulley? Came loose or came off and it snapped the bolt, and it broke, so I got a new pulley and bolt and I am getting it repaired on friday, gonna cost about $130, so im really hoping I didn't do any damage to the engine driving it that few miles, thats what im afraid of =[
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 4:23 PM
Tiny
SATURNTECH9
  • EXPERT
So ur idler pulley under the engine mount come off or did the pulley come off the thing that puts tension on ur belt that is spring loaded?
Louie
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 6:57 PM
Tiny
ASHLEEB
  • MEMBER
The bearings went bad I guess and seized the pulley which made the bolt snap off, from my understanding that is what happened. I had it explained to me, but its hard for me to understand it because I know nothing about it! Lol but thats pretty much how he put it. I'll let you know if it did any engine damage after it gets fixed.
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 7:33 PM
Tiny
SATURNTECH9
  • EXPERT
Well I hope u didn't damage the engine let me know how it goes.
Louie
Was this
answer
helpful?
Yes
No
Wednesday, December 9th, 2009 AT 8:45 PM
Tiny
ASHLEEB
  • MEMBER
It is still being worked on, it should be done today, and I will post the results. Hah
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 3:16 PM
Tiny
SATURNTECH9
  • EXPERT
Looking foward to hearing how it went please let me know.
Louie
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 4:20 PM
Tiny
ASHLEEB
  • MEMBER
I will for sure! It was supposed to be done by today, he said by the end of the weekend, but its still sitting in the same exact place I left it on friday, so I have a feeling its gonna be a few more days but I will let you know when I get it back!
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 5:02 PM
Tiny
ASHLEEB
  • MEMBER
I finally got my car back last night=) luckily theres no knocking and it seems to run just as good as it did before, but I suppose only time will tell. Or when I actually drive it for a while today haha thanks for all your help!
Was this
answer
helpful?
Yes
No
Thursday, December 17th, 2009 AT 9:08 AM
Tiny
SATURNTECH9
  • EXPERT
Glad to hear u have ur car up and running and it wasn't a major ordeal no one needs those especially so close to Christmas. If u car is using oil u mentioned in a earlier post the oil was really low I would suggest next oil change putting in 3 quarts of oil and one quart of Lucas it really helps for cars burning oil it won't burn as much oil with that in engine I use it in my sisters and my saturn works good we used to use it at the Saturn dealer too. It was a pleasure helping ur very welcome iam here to help. Hope u have a very happy holiday.
Was this
answer
helpful?
Yes
No
Thursday, December 17th, 2009 AT 12:00 PM
Tiny
ASHLEEB
  • MEMBER
Yes it burns ALOT of oil its almost ridiculous how much oil it burns, I was supposed to have an oil change over 10,000 miles ago, but everyone told me it was pointless because it burns so much so I don't know, I should have one done anyway I think. But thanks for the suggestion about that stuff, and happy holidays to you too!
Was this
answer
helpful?
Yes
No
Thursday, December 17th, 2009 AT 8:45 PM
Tiny
SATURNTECH9
  • EXPERT
That's not good going 10,000 miles not changing ur oil that's going to cause more engine damage and u too use even more oil if u just add oil and not change it it will sludge up ur engine clog up ur oil ports clog up ur oil filter. No matter how much oil ur car uses u should always chang ur oil every 3,000 miles or 3 months and don't use synthetic oil it burn alot more oil with that.
Was this
answer
helpful?
Yes
No
Thursday, December 17th, 2009 AT 9:17 PM

Please login or register to post a reply.

Recommended Guides