1993 Saturn SL2 tranmission might not be shifting

Tiny
QGABE101
  • MEMBER
  • 1993 SATURN SL2
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 120,000 MILES
I've got a '93 saturn SL2 with about 150,000 miles on it. Recently its been doing this thing where after I"ve been driving for a while, I'll press down the gas pedal and the RPM's will rev, but the car wont accelerate. It's an automatic transmission and I think what's happening is that it has a hard time going to the next gear, and will get stuck in a gear (probably 2nd or 3rd). Sometimes you can feel the car slam or jolt when it's going into the next gear. When this happens the "service engine soon" light comes on. What might the fix be for this or do I need a whole new transmission?
Thank you.
Do you
have the same problem?
Yes
No
Tuesday, April 13th, 2010 AT 11:53 PM

16 Replies

Tiny
SATURNTECH9
  • EXPERT
First let's see what codes u have so we have a starting point on what's going on. Ok lets do this since u have a obd1 system and most auto parts stores can only read obd2 for codes heres what I want u to do. On the drivers side bottom of the dash theres the obd1 connector where u would put a code reader on. Look at the row of it far right side theres two pins side by side. Turn the key to the run postion dont start it and jump those two pins together and leave it that way. Watch the service engine soon light flash.U will see it flash once then two faster flashes. Thats a code 12 that means the computer is good it will do this 3 times if it repeats the code 12 after the 3 times u dont have any codes. But watch the light for example if u see 3 quick flashes then 2 quick ones that would be a code 32 it would repeat 3 times then go to the next code when it gets back to code 12 then the codes are done.
Was this
answer
helpful?
Yes
No
Wednesday, April 14th, 2010 AT 12:00 PM
Tiny
QGABE101
  • MEMBER
Thank you!!! I got codes but i just don't know what they mean... first i got 12 just like you said, then: 26, 11, these came from the SERVE ENGINE SOON light. The following i got from the lights between the BREAK and what I believe is the OIL (both lights flashed together): 22, 23, 24, 76, 78, and 99. After code 99 I got code 12 from the SERVE ENGINE SOON LIGHT. Can you identify these for me??


http://www.2carpros.com/forum/automotive_pictures/516745_0414101303_1.jpg

Was this
answer
helpful?
Yes
No
+1
Wednesday, April 14th, 2010 AT 2:13 PM
Tiny
SATURNTECH9
  • EXPERT
Wow u have alot of codes ur code 26 is a quad fault which is something on ur quad circuit which includes cooling fan spedometer egr solindo canister purge solindo etc. Most likely ur canister purge solindo but thats the least of ur worries right now. Ur code 11 means u have transmission codes. Code 22 is no second gear code 23 is no 3rd gear code 24 is no 4th gear code 76 is a combo code which says second and or 4th gear actuator shorted or open. Code 78 I couldnt find. Code 99 is intermintant pcm failure it says refer to codes 76 and 77 which ever ones u have. What a mess.I would guess its probably electrial problem maybe even ur pcm.U would need a multimeter that does volts and ohms. And be able to do all the checks on circuits. Are u good with all that and willing to take on this type or repair and diagnoses. Its not going to be easy especially since iam not there to see what ur seeing. Let me know what u want to do.
Was this
answer
helpful?
Yes
No
+1
Wednesday, April 14th, 2010 AT 8:11 PM
Tiny
QGABE101
  • MEMBER
With your help I am willing to follow up with the diagnoses and the repairs. I will be as detail with what I see as well. I have a multimeter which does both volts and ohms. I was going to use the meter to check the fuses under the hood but if there is something else I should check as well please let me know. Also I dont know whre to set the meter it has (ACV 200 & 500V), (DCV-500V 200V 20V and 2V), (OMS-200 2K 20K 200K and 2M), (DCA 200mA 20mA, 2mA). I know that for the fuses I use the OHMS and it must be zero, right.
Was this
answer
helpful?
Yes
No
Thursday, April 15th, 2010 AT 12:06 AM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_4th_gear_circuit_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_transmission_wire_diagram_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_76_part_1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_76_part_2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_76_part_3_1.jpg

take ur metter put it on dc 20 start ur car let it idle take and put postive red to red on the car battery and black to black on the battery let me know what ur voltage is at idle on the car idling.then start with checking the underhood fuses all of the fuses starting with trslp trs2 trs3 trs4 and tcc fuses u will have to remove them and check them visually u will be able to see if there blown.do this with the key off.check all the other fuses key on engine off.with ur metter on dc 20 ground the black lead to the battery black post take red lead and test each side of the fuse it should read battery voltage on each side.let me know if any dont and if they dont then turn the key off and pull the fuse and visually check the fuse to see if its blown.i posted the trouble tree for code 76 thats the trouble tree we will start with u always start with electricial codes the other ones 22 23 24 are both mechainicial and electricial.as u can see on code 76 it asks u to start with clearing the codes with a scan tool and see if they reset to see if there current codes or interminatant codes which we cant do we dont have a scan tool to do that.also if we had a good scan tool we code buzz all the actuators for the gears that have codes thru the pcm and see if we have any problems there also.check what i asked so far i will do my best to help u figure this problem out.but no promises to if i can help u all the way thru due to lack of saturn scan tool with all the special tests and other special tools that i usually use and it could be a intermintant problem meaning when we do the tests they could pass but still be bad intermintantly which makes things alot more difficult to diagnose.but i will help u thru this the best i can.let me know what u find and we will go from there.
Was this
answer
helpful?
Yes
No
Thursday, April 15th, 2010 AT 1:46 PM
Tiny
QGABE101
  • MEMBER
Battery voltage was 14.20. the fuse 10 B/U LP had a number 15 fuse so I put on the number 10 fuse. The 7.5 trs4 was blown so I replaced it with another 7.5 fuse. The 10 LH had a number 20 so I replaced it with a number 10. The 15 FOG LP is missing. All fuses passed the battery test with the exception of the 7.5 TRS 2, 3, 4, TCC, LP and the fuse between the TCC and TRS 2. Also the larger fuses to the right were not blowned and passed the battery test. (the problem continues).
PS...i went to an auto shop called Sherys where the perform the OBD1 test, but their devise was not able to detect the vihicle to give me codes or to reset the computer.


http://www.2carpros.com/forum/automotive_pictures/516745_0415101328a_1.jpg

Was this
answer
helpful?
Yes
No
+1
Thursday, April 15th, 2010 AT 3:54 PM
Tiny
SATURNTECH9
  • EXPERT
Yeah non of the trans fuses will have power until the pcm comands power to them thats why I asked u to visually check them. Did the trs 4 fuse blow again?Did u check circuit 1528 to see if its grounded?To check that u would unscrew ur transmission connector the square one on top of ur valve body cover below the battery remove the connector. Put ur meter on 200 ohms scale put black lead to ground and ur red lead to terminal c of the connector the back of the connector is label with letters.U should have no readings to ground just like if the meter wasnt hooked up. Also while u have the connector off with meter on the same scale put it across the terminals on the valve body not the connector starting with g to f- j to h- a to b -e to k it should read around 6 ohms between each terminal use the back of the connector to guide u to which letter pins u need. Let me know what the readings are for each set of pins. Also non of the other fuses for the transmission wernt blown u checked them all visually?Let me know.
Was this
answer
helpful?
Yes
No
+1
Friday, April 16th, 2010 AT 1:45 PM
Tiny
QGABE101
  • MEMBER
The fuses are good none have blown.


http://www.2carpros.com/forum/automotive_pictures/516745_GetAttachment6_1.jpg


is this the connector because it has no lables it is under but next to tha battery...oh i am guessing that the battrey need to be connected at the time of the test...
Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 3:04 PM
Tiny
SATURNTECH9
  • EXPERT
Sorry it took me so long to get back to u I never got a email saying that u posted another reponse. That's the right connector u don't need power from the battery to do those tests. Those letters should be on that connector on the side that has the bolt head where u unscrewed it.U might have to clean up the connector but they are on it. Let me know What u find.
Was this
answer
helpful?
Yes
No
Monday, April 19th, 2010 AT 12:18 AM
Tiny
QGABE101
  • MEMBER
I HAVE NOT BEEN ABLE TO CONNECT TO LET YOU KNOW, MY INTERNET CONNECTION WAS LOST AND I HAD TROUBLE WITH THE COMPANY.///My uncle found me a used transmission and he installed it, but if it is ok with you I would like to continue the diagnostic to the electrical system. Here is what is happening now, when I turn on the car and warm it up it runs well for a few miles then the car will begin to jump when shifting. My uncle's friend ran a diagnostic to the car and found allot of transmission codes. (Oh and I replaced the TPS because I had a code 22 the problem with that code is now fixed.)The new Tranny codes are 14, 69, 68, 65, 55, 53, 51, 48, 47, 43, 42, 41, 26, 24, 21-24, 15. The one that caught his attenssion is code 51 wich means (serial data invalid) he thinks its a bad PCM.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 4th, 2010 AT 12:00 AM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_15_1.jpg


http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_55_1.jpg


http://www.2carpros.com/forum/automotive_pictures/416332_coolant_temp_sensor_19911995_5.jpg


wow what a mess u have that was a big gamble repalcing the transmission like u did.what yr and model car did the transmission come from u got the transmission from?as far as ur codes go starting with ur transmission codes 14-low line pressure69-line pressure actuator shorted to voltage.68-line pressure actuator circuit grounded or open.65-battery voltage too high.55 pcm failure which i posted what it says about that code in the manual.43-enable master relay grounded or open.42-noise on vechile speed sensor.41-vechile speed sensor input not present.26-tcc stuck on.24-no fourth gear.21-2nd gear stuck on.22-no 2nd gear.23-no 3rd gear.24-no 4th gear.now to engine codes.51-faulty prom/mem cal.15-ecm terminal circuit identiy factor which i posted what the manual says about it make sure ur coolant temp sensor wires arent pinched between the engine and transmission bell houslng which is possibly to do.also make sure all the other pires didnt get cut or pinched.looks like from ur codes u have a bad pcm which doesnt mean it will fix all ur codes but there are codes for bad pcm.what i like to do when i have a code for a bad pcm is to clear the codes and see if the bad psm code comes back if it does then replace the pcm makes me feel better about replacing it.whats scarey though in ur case is u didnt have all these bad pcm codes before u changed ur transmission.and u have almost all new codes and new ones u didnt have before u changed ur transmission.the best way to go with ur pcm would probably be used cheaper and u might avoid havubg to program it.if u went new u would for sure have to have it programed.u can use 93 or 94 twin cam automatic pcms there the same part numbers.they have alot of them on ebay u just put in saturn pcm or ecm and search thru them all.i just checked autozone and kragen looks like its not available new in aftermarket.the dealer one new is 542.00 so looks like used on that one.if memorey serves correct if go with the used pcm then if ur car had cruise control and the car the pcm came from didnt then ur cruise wont work until u have that turned on at the dealer.let me know what u find.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 4th, 2010 AT 3:36 PM
Tiny
QGABE101
  • MEMBER
Is there anything I should know before intalling the PCM? What if the previous car had cruise control? My car does not have that feature/. The car I got it from is a 94 and it has different numbers on it.
Was this
answer
helpful?
Yes
No
+1
Thursday, May 6th, 2010 AT 5:47 PM
Tiny
SATURNTECH9
  • EXPERT
My mitchell on demand listed the same part numbers for the 93-94 twin cam automatic transmission pcms did u get a automatic transmission one with three connectors on it.U have a differnt number on the 94 is there anyway u can return it for a 93?Before u install it?I would hate because it has differnt numbers for it not to work and u not be able to return because u installed it. Other then that it would just be plug and play and if ur car has no cruise control then no worries if the car did. Let me know.
Was this
answer
helpful?
Yes
No
+1
Thursday, May 6th, 2010 AT 6:36 PM
Tiny
QGABE101
  • MEMBER
I changed the PCM with a maching atomatic 1993 transmission and its running smoothere, now my question is with code 41-vechile speed sensor input not present. What sensor is it refering to? Autozone told me that there are two sensors. Vihicle speed sensor, and transmission speed sensor.
Was this
answer
helpful?
Yes
No
+1
Tuesday, May 11th, 2010 AT 6:45 PM
Tiny
SATURNTECH9
  • EXPERT


http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_speed_sensor_wire_diagram_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_code_41_trouble_tree_1.jpg



http://www.2carpros.com/forum/automotive_pictures/416332_1993_sl2_speed_sensor_1.jpg


glad to hear ur down to one code now the sensor ur looking for is number 36 on the pic i posted.the other sensor autozone was talking about is the input speed sensor its by transmission filter.differnt code for that though.i also posted a wire diagram for the speed sensor and a code 41 trouble tree for u.let me know what u find.
Was this
answer
helpful?
Yes
No
+1
Wednesday, May 12th, 2010 AT 1:35 PM
Tiny
QGABE101
  • MEMBER
I cant read the diagram is it posible if you can send a larger version to my e. Mail
Was this
answer
helpful?
Yes
No
Wednesday, May 12th, 2010 AT 8:29 PM

Please login or register to post a reply.

Recommended Guides