2001 Saturn SL1 Blower motor doesn't work

Tiny
MJSIMON
  • MEMBER
  • 2001 SATURN SL1
  • 4 CYL
  • 2WD
  • MANUAL
  • 160,000 MILES
I get 12 volts with the switch on and 0 when it is off, so I thought I needed to replace the blower motor. I installed a new one, but it still does not turn on.
Do you
have the same problem?
Yes
No
Monday, October 12th, 2009 AT 12:26 PM

3 Replies

Tiny
IMPALASS
  • EXPERT
Hello -

Please check the HVAC fuse (15-amp), located in instrument panel fuse block. If fuse is blown replace as necessary. Please check it with an ohm meter or a known good fuse.

Check for loose connections at blower motor relay, located in instrument panel fuse block.
Was this
answer
helpful?
Yes
No
+2
Monday, October 12th, 2009 AT 1:51 PM
Tiny
MJSIMON
  • MEMBER
I tried both of your suggestions. I replaced the 15 amp fuse (though the old one looked fine) with a new one. I swapped the fuel pump relay with the one for the HVAC to see if that was the issue and did not get a difference. I do hear a small popping sound when switching the fan speed back and forth between 3 and 4 and no other times.

Any other suggestions would be helpful and thanks for your initial reply.
Was this
answer
helpful?
Yes
No
+1
Monday, October 12th, 2009 AT 2:55 PM
Tiny
IMPALASS
  • EXPERT
Hello -

Okay, then we need to check the switch..........

BLOWER SWITCH
Disconnect A/C-heater control panel (HVAC control head). Using DVOM, check continuity of blower switch. See BLOWER SWITCH CONTINUITY table. Ensure continuity exists between terminals specified.


http://www.2carpros.com/forum/automotive_pictures/248015_Picture1_95.jpg




http://www.2carpros.com/forum/automotive_pictures/248015_Picture2_61.jpg


Was this
answer
helpful?
Yes
No
-1
Monday, October 12th, 2009 AT 9:33 PM

Please login or register to post a reply.

Recommended Guides