1998 Saturn SL1 Sputtering/decrease in RPM's

Tiny
KVAZQUEZ
  • MEMBER
  • 1998 SATURN SL1
  • 4 CYL
  • FWD
  • MANUAL
  • 132,000 MILES
For awhile now, my saturn has, when at a stop, the rpm's will drop suddenly and then come back up to normal range. Now, as of today, that happened as usual but it's actually trying to die. I have gone through sparkplugs/wires every 6 months. Please let me know what your take is on this. Also about 2 years ago the mechanic said the engine light was reading a bad knock sensor. Would this be it? Since then the light has gone off.
Do you
have the same problem?
Yes
No
Monday, March 1st, 2010 AT 4:10 PM

4 Replies

Tiny
SATURNTECH9
  • EXPERT
If ur knock sensor was that bad ur engine light should have come back on.I would have it checked for codes though and let me know what numbers they are if u have any. What kind of wires are u putting on that u need to change them every 6 months I can't think of a engine problem that would cause them to go bad every 6 months are u using cheap ones?If u are then I would use some a/c delco wires. Why are u replacing ur plugs every six months are they getting fouled?How much oil are u burning?Theres a coolant temp sensor screwed into ur head below where ur upper hose goes unplug that by squeezing it. Look at the coonector if its corroded u will need to replace or clean it. Its real common for the sensors to crack and leak into connectors. The sensor controls how much fuel ur engine gets the cooling fan and even temp gauge. And will cause ur engine to flood. There under 20 to replace if u replace it make sure u get a brass tipped one not a plastic tipped one they crack. Let me know what u find. Thats where I would start.
Was this
answer
helpful?
Yes
No
Monday, March 1st, 2010 AT 4:37 PM
Tiny
KVAZQUEZ
  • MEMBER
The plugs get covered in oil and causes the engine to misfire. As far as the codes, I will go to autozone this evening and have them hook the computer up and see what it's reading. Appreciate the help!
Was this
answer
helpful?
Yes
No
Monday, March 1st, 2010 AT 4:58 PM
Tiny
SATURNTECH9
  • EXPERT
Sorry I havent gotten back to u sooner but I was expecting u to bring back those codes to me and I was going to reply then. Did u get the codes yet?Did u check ur coolant temp sensor yet?As far as ur oil burning not a whole lot u can do there a side from a engine swap.U could put in some lucas oil stabilizer that helps slow the oil burning down. Let me know what u find.
Was this
answer
helpful?
Yes
No
Wednesday, March 3rd, 2010 AT 12:31 PM
Tiny
KVAZQUEZ
  • MEMBER
I have not yet got a chance to get those codes although I appreciate your willingness to explain what they are. Very Helpful! I did change out spark plugs and wires again, one had a rip in it already. I did purchase a new coolant temp sensor but have yet to swap it out. So far with the new wires and plugs, the car has been doing great. Thanks for the help, very greatly appreciated!
Was this
answer
helpful?
Yes
No
Wednesday, March 3rd, 2010 AT 12:36 PM

Please login or register to post a reply.

Recommended Guides