1994 Saturn SL1 What happened

Tiny
MOKY_MARK
  • MEMBER
  • 1994 SATURN SL1
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 136,000 MILES
I recently was driving home from work and I noticed my car not shifting as it should be. I also noticed I had loss of power in low gear so I stoppped and thought it just needed to cool down. Well when I went to start it again it would not. So I got a jump from a passerby it started right up. So as I was leaving I stepped on the gas and it felt as if my car would not shift pass first gear. Then my speedometer and odometer stopped reading alltogether but the car was still running and I wanted to see if I could make it home. It was getting dark so I tried the lights and when I went to turn them on it felt as if my car just shut off so I quickly turned them them back off and my car felt like it was on but still loss of power I made it home but now it will not start PLEASE help me figure this out I need this vehicle to earn a living I put a used but new engine in it recently
Do you
have the same problem?
Yes
No
Wednesday, June 23rd, 2010 AT 1:24 PM

1 Reply

Tiny
SATURNTECH9
  • EXPERT
First thing I want you to do is take out the battery and have it charged and tested if it test's good then put it back in. If it test's bad then I want you to get a new battery and put that in. Once you get that done then start the car and take a multimeter across the battery terminal's tell me what the voltage is at idle. It sound's like you have a bad alternator.
Was this
answer
helpful?
Yes
No
Wednesday, June 23rd, 2010 AT 1:40 PM

Please login or register to post a reply.

Recommended Guides