1999 SL2 intermittent stalling/dieing

  • 1 POST
  • 1999 SATURN

This car had a nerw crank sensor installed elswewhere before I got the car to work on. Had DTC's for cam sensor error (module driven, cyl #4 signal) and a I believe P1539 or so (at or near stalling condition) Car has 122,000 miles on it. Never been tuned up. Installed new plugs, wires, coils/EI Module, fuel and air filters.

Codes do not return but intermittent stalling still exists per customer's daughter, never stalled for me yet.

tested crank sensor resistance, 883 ohms, not sure what brand, tested new saturn crank sensor, measured 835 ohms, cranking Hz is approx 35 Hz, Idle (not fully warmed) is approx 120 Hz at idle. Tested power grounds at PCM (.02-.06V) drop from PCM to Bat neg. All power feeds to PCM 14.2-14.3 even when wiggling key in ign switch.

Trying real hard not to get any grayer hair on this one, any help would be appreciated.


Do you
have the same problem?
Thursday, March 22nd, 2007 AT 7:10 PM

1 Reply

  • 1,159 POSTS

Hey JJ,
Might be chasing an electrical ghost on this one. Maybe something gummed up like a EGR valve pintle or an idle air control. At close to a 100,000 miles good idea to clean them along with the throttle body.

Scope the throttle position sensor. When they are just starting to fail they will spike voltage at times but not set a code.

Wish I could get gray already am. :)

Good hunting and let us know.

Was this
Wednesday, April 4th, 2007 AT 8:44 AM

Please login or register to post a reply.

Recommended Guides