1996 SATURN SL2 STARTS ROUGH, THEN DIES

  • Tiny
  • Gridarm
  • 1996 SATURN

I have a 96 Saturn SL2, dual cam 160k miles It's been running great untill 3 days ago, now on a cold start, the engine sputters, untill it gets up to RPM, then runs smooth, on a hot start, it sputters, then dies, the only way to get it to start is to hold accelerator down then it starts rough untill it gains RPM. Then runs smooth, I've noticed a strong exhaust smell now, and black soot coming out of the tail pipe. If I push the accelerator fast, the engine chokes. It has all new injectors, plugs, plug wires, and fuel filter. There was also black soot, on the plugs. I've also noticed a slight ping in the engine, that comes and goes. Although, I'm not sure if it's just the muffler rattling.
The past few day, it's seemed to get a little worse.
Any advise would be greatly appreciated.

Do you
have the same problem?
Yes
No
Tuesday, April 10th, 2007 AT 9:00 PM

4 Replies

  • Tiny
  • Jack42
  • MEMBER

Maybe an oxygen sensor, I dont think you have a Mass Airflow Meter, so possibly a MAP sensor

Was this
answer
helpful?
Yes
No
Monday, April 16th, 2007 AT 8:05 AM
  • Tiny
  • Wscreate
  • MEMBER

I'm just a nubie, but I have a 94 Saturn which had similar symptoms. I replaced the coolant temp sensor for the PCM (NOT the gauge) and my problems have disappeared.

This little $20 piece corrected the following problems on my Saturn.

--- Rough, idle, fluctuated from 800 - 1600 rpm
--- Car died after idling for a few minutes
--- Pushing the accelerator caused the engine to choke, sputter and die
--- To start the car when warm, had to press the accelerator all the way to the floor while turning the engine over.

Here is a link to the thread where I got help.
http://www.2carpros.com/forum/94-saturn-sc2-idles-goes-up-and-down-then-wont-start-vt35660.html

Was this
answer
helpful?
Yes
No
Tuesday, April 24th, 2007 AT 8:29 PM
  • Tiny
  • Peppermrj
  • MEMBER

Hey Gridarm,

Is the ses light lit? Most times an O2 sensor that Jack mentioned will set a code. Not sure about the MAP sensor. No mass air flow meter on your satty.

Ws is on the right track with the ECTS. It has a very large effect on the PCMs regulation of the air fuel mixture. When it fails it tells the computer it is cold even when it is hot. If it totaly fails the computer will read about 40 below. That would explain the rich mixture (black soot).

Good luck and let us know. :)
peppermrj

Was this
answer
helpful?
Yes
No
Wednesday, April 25th, 2007 AT 5:55 PM
  • Tiny
  • Barberton1
  • MEMBER

Replace the ECT sensor make sure its the one for the computer not the gauge your old one will be cracked regardless of brass or plastic tip, make sure you have a replacement from saturn or equivilant from advance auto parts or autozone BWD Part# WT5029 with the brass tip and make sure your connector is corrosion free. This is 99% sure fix for your start up and choke out problem. Hope this helps you out.

Was this
answer
helpful?
Yes
No
Friday, September 25th, 2009 AT 2:21 PM

Please login or register to post a reply.

Other Engine Stall Questions