2003 Saturn L200 ALtern, Battery, A/C problems? HelP!

Tiny
MR.HONDA24
  • MEMBER
  • 2003 SATURN L200
Electrical problem
2003 Saturn L200 4 cyl

Hi I recently worked on my vehichle to try and get my a/c working.
At first I had no refrigerant in system because of condenser and radiator being replaced, however, I filled about 2 12oz of 134a into system with vehicle ac compressor on. I could not find any leaks, gauge never read filled. However during charging the system, compressor clutch started to jump and jump. Me and a friend jumped the high pressure sensor and stayed on.

A/c relay was tested and was fine.
During all of this the compressor clutch would jump with ac button on and pull a load, low idleing.

I had a battery issue after this and my alternator had to be taken in.
- I had someone replace a regulator on it that went bad
Car runs but battery indicator light still stays on without Air condioner running

All fuses are ok, maxi's, relays.

What could be the problem? Alternator fusible link? Please Help
Do you
have the same problem?
Yes
No
Thursday, April 8th, 2010 AT 5:05 PM

9 Replies

Tiny
SATURNTECH9
  • EXPERT
U put 1.5lbs of charge in the system u are still low it takes 2.09lbs u are low by over a half of pound. That could be ur problem with ur a/c cycling I would start there. With ur alternator u could just have a bad one there. See if u have 12 volts to the back larger post. Let me know what u find.
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 11:22 AM
Tiny
MR.HONDA24
  • MEMBER
Ok the only helpful data at the moment I can give is that with car running, and neg cable off- I can still pull loads such as headlights, windows, fan motor. However check engine light, service repair soon came on, but no abs warning

Note; cooling fan 2(condenser fan) fuse pops when ac button is pushed on. WHERE are relays for cooling fan?

I have no multimeter right now, cuz I rely on some friends that have other tools (that I usually do not have)to get jobs done quicker

i reconnected alternator sensor several times to make sure connection seems good, however battery ight still comes on after each connection
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 4:13 PM
Tiny
SATURNTECH9
  • EXPERT
Sounds like the alternator is working but u will have to borrow ur friends meter to checking the charging volts to see if it's the alternator or wiring to the car turning the battery light on. Ur fan relays are in that box right by ur battery.U say ur cooling fan fuse is blowing when u turn the a/c on then unplug ur cooling fan motor on ur a/c condensor the one facing ur front bumper replace ur fuse push the a/c button if the fuse blows again u know the short is on the circuit side if it doesn't blow then u know it's ur fan motor blowing the fuse. Let me know what u find.
Was this
answer
helpful?
Yes
No
Saturday, April 10th, 2010 AT 10:45 AM
Tiny
MR.HONDA24
  • MEMBER
Alt reads the 14 volt on battery while run

Alt reads 12 volt on battery turn off

Havent been able to test long enough to see any jumps.

Cooling fan fuse blows with a/c button turned on.
Was this
answer
helpful?
Yes
No
Saturday, April 10th, 2010 AT 6:18 PM
Tiny
SATURNTECH9
  • EXPERT
Did u unplug ur condensor fan see if the fuse still blew when u turned on the a/c?Find out what codes u have so we can figure out ur battery light problem. Let me know what codes u have and if the fuse blew with the fan unplugged.
Was this
answer
helpful?
Yes
No
Sunday, April 11th, 2010 AT 2:06 PM
Tiny
MR.HONDA24
  • MEMBER
2003 SATURN L200 reply> Condenser fan is new. All fuses are good, relay works, and it has almost 3 cans of 134a w/oil in it. A/C clutch jumps on and off while driving or raising throttle? And no cold air.

Also, I bypass pressure switch and compressor clutch fails to even come on

I have yet to have someone evac and recov. System because I do not believe that is the problem. Plus it is expensive. And sometimes $rip off schemes- with the recovery machine.
Was this
answer
helpful?
Yes
No
Saturday, May 8th, 2010 AT 1:23 PM
Tiny
SATURNTECH9
  • EXPERT
So was the condensor fan the reason for the fan fuse to blow?Does the condensor fan come on when u turn the a/c on?How many ounces is in each r134 can ur putting in?Also how much r134 was in the system before u started charging it?The system holds a little less then 33.6 ounces an if u over charge it or ur condensor fan doesn't come on to cool the gas in ur caondensor then the compressor will cycle. Did u ever get any trouble codes out of the car?
Was this
answer
helpful?
Yes
No
-1
Sunday, May 9th, 2010 AT 10:57 AM
Tiny
MR.HONDA24
  • MEMBER
No trouble codes, fan fuse works, condenser works when bypassing pressure switch. And when ac button and fan nob switch is turned on.
Was this
answer
helpful?
Yes
No
Sunday, May 9th, 2010 AT 6:43 PM
Tiny
SATURNTECH9
  • EXPERT
Sounds like u need to make sure u have the right amount of a/c charge in ur system and check ur suction and discharge pressures to see if the compressor is cycling because of too much pressure or too little pressure that way u can see if it's that or pressure switch. Let me know what u find.
Was this
answer
helpful?
Yes
No
Sunday, May 9th, 2010 AT 6:52 PM

Please login or register to post a reply.

Recommended Guides