Sat for 3 months, now its running rough.

Tiny
ATRAI1288
  • MEMBER
  • 1999 VOLVO S70
  • 183,000 MILES
The car has sat for 3 months. When I went to start it the battery was dead so I jumped it. Start right up, no problems at all. Ran it for about 30 minutes to charge up the battery then shut it off. I waited 10 minutes then started it back but and the car surged to 2000 rpm then dropped to 800, ran rough, fluctuating between 900 and 500 at an idle. It runs clean at above 1800. I was thinking maybe the fuels gone bad or a blocked fuel Injector. The fuel was not stabilized before storing. The other possibility I considered was a bad battery/alternator. While it's struggling at an idle the interior lights flicker.
Do you
have the same problem?
Yes
No
Wednesday, July 17th, 2013 AT 11:39 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
The fuel should be okay after 3 months. As far as the flickering lights, have the alternator tested. It sounds like you have a bad voltage regulator. Most parts stores will test it for free.
Was this
answer
helpful?
Yes
No
Wednesday, July 17th, 2013 AT 1:07 PM
Tiny
ATRAI1288
  • MEMBER
Would this also cause the rough running? Because I am certain the two are related as the lights flicker in time with the engine.
Was this
answer
helpful?
Yes
No
Wednesday, July 17th, 2013 AT 1:16 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If the voltage to the ignition system is weak, it could cause it.
Was this
answer
helpful?
Yes
No
Wednesday, July 17th, 2013 AT 6:07 PM

Please login or register to post a reply.

Recommended Guides