2006 SAAB 9-3 repair Question Car runs weird when parked out

  • 1 POST
  • 2006 SAAB 9-3

Engine Performance problem
2006 Saab 9-3 repair Question 6 cyl Two Wheel Drive Manual 40000 miles

My car, after a warm restart runs like crap. At the lower speeds (when trying to bring the rpms up while barely feathing the pedal) the car bucks, shrugs, and has serious power loss. Now if I mash the pedal when those symptoms are happening, the bucking stops, but the car gains speeds as slow as a turtle.

I've spoken to the dealer about it and they said "they couldn't replicate it" When those symptoms happened, I had Knock retard up to 7.

No CEL's have been thrown and this is making it difficult to diagnose. I will be speaking to my dealer about this again today and any help would be appreciated.

Please note that after the car has reached optimal tempratures, it runs beautifully, and that this problem only started when the temperature outside have been cold.

EDIT: You should also know that my car has an after market tune. Those symptoms are present on both tuned and stock, but are way more pronounced when tuned.

I use 94 octane as well.

Thanks a lot.

Do you
have the same problem?
Tuesday, February 23rd, 2010 AT 11:10 AM

1 Reply

  • 13,549 POSTS

Hello .. thanks for the donation .. much appreciated

I would be checking you are getting the correct readings from the MAF (mass airflow) sensor .. also IAT (intake air temp) sensor .. these should throw codes and display CEL .. but this is not always the case !!

hope this helps


Was this
Wednesday, February 24th, 2010 AT 8:39 PM

Please login or register to post a reply.

Recommended Guides