Running rough

  • 1998 ACURA TL
  • 2.5L
  • 5 CYL
  • FWD
  • 236,000 MILES

I bought this car in February drove it for three days ran perfectly. Then one day went to get in it and no crank no start so put new starter battery and alternator still nothing checked all fuses and relays all good. Towed to a shade tree mechanic soon as he got in it started turning over but no crank. He replaced the coil pack and igniter and then told me to pay him $150.00 and come get the car so got it back called a mobile mechanic and found out it was not getting fire or fuel so replaced main relay and fuel pump and plugs wires and coil pack, by the way when plugs were replaced all plugs had oil on them. But after all that nothing so we started feeling around and found a ground just hanging from a knock sensor attached it to the fender well and it started right up with a skip I figured since it was sitting for a while it just needed to be ran for a while so now we are on week two and when in neutral or park idles at 1000 rpm's in reverse or d4 sits at 500 press gas it wants to shut off. Could the timing be off a little or what? Please help I am going through gas like water.

Do you
have the same problem?
Friday, May 12th, 2017 AT 7:15 PM

1 Reply


Scan for codes and check fuel pressure start parts rent gauge either can be the problem but having oil on spark plugs is not a good sign. you may need an adapter to check fuel pressure. Also check for a vacuum leak. See link.
one other thing, clean throttle plate on both sides and IAC hole with choke cleaner.

Was this
Saturday, May 13th, 2017 AT 6:29 AM

Please login or register to post a reply.

Recommended Guides