RPM drops when A/C turned on

Tiny
MIRZA AHMER
  • MEMBER
  • 2017 SUZUKI WAGON
  • 1.0L
  • 3 CYL
  • 2WD
  • MANUAL
  • 14,000 MILES
It is summer in my country and AC is a must. But I am having troubles with the rpm. In the morning I first let the engine get running for a minute or so and then turn the AC on at 2. The rpm drops to 500 and then after jumping between 500 to 800 gets normal after a while. Sometimes while driving when AC is on and I brake the car and press clutch rpm drops to 500 and car vibrates this shouldn't happen usually. I faced this situation a few miles back and get the throttle body serviced everything went normal. It is happening again. And even when engine is in running condition and I turn AC to 4 rpm jumps between 500 and 1200 continuously for a while. What is the reason and how to get it fixed? Video attached below when engine is hot and AC is switched to 4. PS: air filter and spark plugs are timely changed.
Do you
have the same problem?
Yes
No
Tuesday, April 30th, 2019 AT 5:50 AM

1 Reply

Tiny
SCGRANTURISMO
  • EXPERT
Hello,

What this looks to me like is probably an vacuum leak. When your engine rpm's are hunting" like that, it's almost always a vacuum leak. I have included a link down below for you to go to:

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Please go through this guide and get back to us with what you are able to find out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Tuesday, April 30th, 2019 AT 7:35 AM

Please login or register to post a reply.

Sponsored links