2002 Rover 25 high revs

Tiny
SHEFFWEDFAN
  • MEMBER
  • 2002 ROVER 25
  • 4 CYL
  • FWD
  • MANUAL
  • 585,000 MILES
My rover 25 starts ups and idles at 1100 rpm as it should but as the engine gets warm my rev counter rises and starts to idle at 1500 rpm but engine is not racing does this mean that my idle air control valve is faulty thanks
Do you
have the same problem?
Yes
No
Wednesday, August 19th, 2009 AT 11:33 AM

13 Replies

Tiny
DOCFIXIT
  • EXPERT
Maybe or engine coolant temp sensor
Was this
answer
helpful?
Yes
No
Wednesday, August 19th, 2009 AT 11:58 AM
Tiny
SHEFFWEDFAN
  • MEMBER
Ive replaced the cts
Was this
answer
helpful?
Yes
No
Wednesday, August 19th, 2009 AT 12:36 PM
Tiny
DOCFIXIT
  • EXPERT
Try cleaning IAC and passageways. Check for vacuum leaks also clean throttle body maybe carbon on plate
Was this
answer
helpful?
Yes
No
Wednesday, August 19th, 2009 AT 1:37 PM
Tiny
SHEFFWEDFAN
  • MEMBER
Ive try cleaning the iacv but a sealed unit, cleaned the tb and ive tried spraying wd40 on engine for leaks I think I can hear a leak but not sure if this is normal
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 9:11 AM
Tiny
DOCFIXIT
  • EXPERT
For vacuum leak use carb cleaner when it hits leak idlewill change.
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 9:24 AM
Tiny
SHEFFWEDFAN
  • MEMBER
Where do I spray the carb cleaner to find leak, if there is no air leak is the iacv at fault
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 11:17 AM
Tiny
DOCFIXIT
  • EXPERT
Try unpluging IAC and repluging can you hear motor run? I don't have acess to Rover info but there should be test proceedures like Ohm checks.
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 11:30 AM
Tiny
SHEFFWEDFAN
  • MEMBER
When I turn the engine off I can hear the motor on the iacv working but how far should the plunger move, when I tried cleaning and switched the igniton on I saw the plunger move
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 11:43 AM
Tiny
DOCFIXIT
  • EXPERT
Could try an experiment remove IAC and plug off airway. Start see if it still idles at 1500
Was this
answer
helpful?
Yes
No
Thursday, August 20th, 2009 AT 12:02 PM
Tiny
SHEFFWEDFAN
  • MEMBER
Ive tried removing the iacv and plugging up the airway but the car will not start unless someone is manually opening the butterfly vakve on throttle body I have changed the cts but is it possible that they supplied me with the wrong one
Was this
answer
helpful?
Yes
No
Friday, August 21st, 2009 AT 9:06 AM
Tiny
DOCFIXIT
  • EXPERT
That tells me that air is not getting around throttle plate so IAC looks suspect.
Was this
answer
helpful?
Yes
No
Friday, August 21st, 2009 AT 9:17 AM
Tiny
SHEFFWEDFAN
  • MEMBER
Ive replaced the iacv with a secondhand one and still the same problem but I cant hear any air leaks now is it possible the lambda sensor is faulty
Was this
answer
helpful?
Yes
No
Monday, August 24th, 2009 AT 12:02 PM
Tiny
DOCFIXIT
  • EXPERT
http://www.2carpros.com/forum/2002-rover-25-high-revs-vt337616.html
Check out this post almost same problem. Maybe you two should exchange notes
Was this
answer
helpful?
Yes
No
Monday, August 24th, 2009 AT 12:10 PM

Please login or register to post a reply.

Recommended Guides