Ran put of gas now service engine soon light is on

Tiny
CADDYELDO
  • MEMBER
  • 2001 CADILLAC EL DORADO
  • 4.6L
  • V8
  • FWD
  • AUTOMATIC
  • 110,000 MILES
I recently ran out of gas and after I put gas in it and ran it the service engine light came on now when I Drive it the service engine light blinks I've changed the spark plugs I've changed the fuel filter and II also changed the ICMwhat the problem persists when I am at a dead stop at a stop light or stop sign and I push the gas to go it kind of spudders before it actually move at a high rpm the service engine light blinks for once I come to a stop its on solid when I took it to Autozone they told me it was my ICM you so I replaced it but still no go so now I am all out of solution any help would be greatly appreciated
Do you
have the same problem?
Yes
No
Wednesday, January 1st, 2014 AT 6:03 PM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
That isn't an ICM issue. Listen, since the problem started when you ran out of gas, I would recommend checking fuel pump pressure. Very often, the pumps go bad when they run dry. Also, check the fuel filter to make sure it isn't plugged with dirt from the bottom of the tank.

As far as the check engine light flashing, that tells me there is an engine misfire. You may even have an issue with a dirty injector at this point. Can you get me the codes that were pulled from the computer at AZ? That would help me to direct you.

If you can't, check the fuel pump pressure to make sure it is within the manufacturer's specs, replace the fuel filter, and run a good fuel injector cleaner through the system to see if that helps.

Let me know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, January 1st, 2014 AT 6:28 PM
Tiny
CADDYELDO
  • MEMBER
Thank you for your help I got the code its is p0306 that is the only code that came up I changed the fuel filter it was clogged up I also changed my spark plugs but still no luck I will be checking the pressure of the pump today and see how that is what is. The correct psi it ahould be at
Was this
answer
helpful?
Yes
No
Friday, January 3rd, 2014 AT 12:22 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
The PO306 is a misfire on cylinder 6, Have you checked coils, fuel injectors.
Was this
answer
helpful?
Yes
No
Friday, January 3rd, 2014 AT 4:16 PM
Tiny
CADDYELDO
  • MEMBER
I checked thd plugs replaced all of them and got a replacement coil pack from the junk yard and checked the fuel pressure at the rail and it was at a steady 40 psi is that normal also I change the filter and it was a little clogged up also used a mechanics stethescope and checked the injectors and I hear each one clicking on but is the clicking a fast paced clicking sound or is it supposed to be a slow paced clicking
Was this
answer
helpful?
Yes
No
Tuesday, January 7th, 2014 AT 1:08 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I believe you have the 4.6L engine, correct? If so, my manual is showing between 52 and 60psi for the fuel pump.

As far as the clicking from the injectors, that will be fast.
Was this
answer
helpful?
Yes
No
Tuesday, January 7th, 2014 AT 5:36 PM
Tiny
CADDYELDO
  • MEMBER
So do you think that I need to replace the fuel pump and that is correct it is the correct engine I guess that will be my next step replacing the pump thanks for the help and the knowledge on the correct psi
Was this
answer
helpful?
Yes
No
Tuesday, January 7th, 2014 AT 10:13 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Yes, that is what Mitchelonline says the pressure should be. I hope that takes care of it for you.
Was this
answer
helpful?
Yes
No
Wednesday, January 8th, 2014 AT 7:18 AM

Please login or register to post a reply.

Recommended Guides