Loud noise coming from the front after replacing the rack and pinion

Tiny
SHELLY LAMBERT
  • MEMBER
  • 2005 PONTIAC G6
  • 3.1L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 170,000 MILES
We replaced the rack and pinion as well as our tie rod ends on our car and now there is a loud squealing and rubbing sound in the front. Help what it is?
Do you
have the same problem?
Yes
No
Tuesday, September 15th, 2020 AT 2:04 PM

2 Replies

Tiny
KASEKENNY1
  • EXPERT
More then likely this is air in the power steering system or your rack is faulty. Can you get a recording of the noise and then give us the procedure you used to purge the air out of the system?

Here is a guide on how to flush the system which may be the best idea at this point:

https://www.2carpros.com/articles/power-steering-fluid-flush

Let me know if you can get the video and we can go from there. Thanks
Was this
answer
helpful?
Yes
No
Tuesday, September 15th, 2020 AT 6:25 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

Do you only hear the noise when the vehicle is moving? Have you inspected the rear of the tires to make sure nothing is touching? Was the vehicle aligned after the work was done? Is there anything that changes the sound's pitch? For example, when applying the brakes does it change? Was the new rack and pinion properly bled when it was installed?

If the sound is evident when the vehicle is not moving, open the hood and inspect the accessory drive belts to make sure nothing is making contact.

If possible, record the sound and upload it for me so I can hear it. Let me know anything you can think of that will help me with the diagnosis.

Take care,
Joe
Was this
answer
helpful?
Yes
No
Tuesday, September 15th, 2020 AT 6:26 PM

Please login or register to post a reply.

Sponsored links