PROBLEM WITH LOST DRIVE POWER AFTER ENGINE WASH

Tiny
WARUGONGO
  • 2006 NISSAN SERENA
  • 35,000 MILES

I own a Nissan Serana Rider S Autotech C25 2006 model. I took this car for engine wash then thereafter the car started jacking and lost drive power as drove back home. Allover a sudden the dashboard control light i.E "P" "R" "N" "D" "L" disappeared, I went back where the car was done engine wash and used pressure to blow off excessive water from control sensors. We switched on the engine the control lights came back but "D" light failed completely even after several trials.
At the moment the car gains drive power when I try to drive front and back the it shows "N" even when engaged to drive gear then it lost both drive and reverse power completely.

Now, I was advice by Mr. Roy to TAKE OFF BATTERY CABLE AND RE INSTALL TO RE BOOT SYSTEM the process I have done already but the problem still persisted.

Now, Could it be a problem with Gearbox Transmission Computer or the sensors if so which sensor could be a problem<

Please help.

Kind regard,

Francis.

Do you
have the same problem?
Yes
No
Friday, April 19th, 2013 AT 2:00 AM

1 Reply

Tiny
ASEMASTER6371
  • EXPERT
  • 25,554 POSTS

You have an electrical issue resulting from the engine wash.

Water got into something electrical and is causing this codition. You need a shop to help you track it down as we cannot see it or touch it to go further

Roy

Was this
answer
helpful?
Yes
No
Friday, April 19th, 2013 AT 3:03 AM

Please login or register to post a reply.

Other Engine Clean Questions