Popping the 50 amp ignition fuse under hood

Tiny
DENNIS BARNES
  • MEMBER
  • 1998 FORD RANGER
  • 2.5L
  • 2WD
  • MANUAL
  • 200,000 MILES
I drove my truck to a job went to start it when I was leaving and nothing found the 50 amp fuse under hood was bad replaced it had dash lights again, but tried to start it and it popped the fuse again.
Do you
have the same problem?
Yes
No
Saturday, July 28th, 2018 AT 8:40 AM

6 Replies

Tiny
KEN
  • ADMIN
Can you upload a picture of the fuse that blows in and the fuse panel and location? Because it is not showing the ignition 50 amp fuse. I will be able to look it up from the location and then see what it powers so we can fix the problem.

Please report back.

Cheers, Ken
Was this
answer
helpful?
Yes
No
-1
Sunday, July 29th, 2018 AT 2:21 PM
Tiny
DENNIS BARNES
  • MEMBER
It is the engine compartment fuse relay box under the hood drivers side and it is the number 5 slot 50 amp ignition.
Was this
answer
helpful?
Yes
No
Sunday, July 29th, 2018 AT 9:26 PM
Tiny
DENNIS BARNES
  • MEMBER
Hey Ken, I replaced the starter the solenoid was bad. Now no blown fuses and it turns over but will not start like it is not getting fuel.
Was this
answer
helpful?
Yes
No
Monday, July 30th, 2018 AT 10:28 PM
Tiny
KEN
  • ADMIN
Nice work on that sorry for the late response. I would check the inertia switch. Push down on the button on top to see if it has been tripped.

Check out the diagrams (below). Please let us know what happens.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 10:45 AM
Tiny
DENNIS BARNES
  • MEMBER
I am sorry Ken, it is not getting spark.
Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2018 AT 8:07 PM
Tiny
KEN
  • ADMIN
Can you see if you are getting injector pulse? Here is guide to help:

https://www.2carpros.com/articles/how-to-test-a-fuel-injector

Please run down this guide and report back.

Cheers, Ken
Was this
answer
helpful?
Yes
No
Wednesday, August 1st, 2018 AT 4:11 PM

Please login or register to post a reply.

Sponsored links