Fuel pump

Tiny
OBEE
  • MEMBER
  • PONTIAC GRAND PRIX
I had a fuel pump installed in my 1990 Grand Prix, 3.2 four quad engine. The pump does not quit running and is not pumping any fuel and the the fuel guage stays way past full. HELP!

Thank You,

obee
Do you
have the same problem?
Yes
No
Thursday, August 30th, 2007 AT 5:09 AM

3 Replies

Tiny
SERVICE WRITER
  • EXPERT
2.3 maybe?
Was this
answer
helpful?
Yes
No
Thursday, August 30th, 2007 AT 9:02 AM
Tiny
OBEE
  • MEMBER
Are you thinking it is not a 2.3? I am sure it is a 2.3, however there is some things that don't line up just right.I bought the motor new and I am thinking it is not a 1990 like I need. Reguadless the fuel pump must be installed wrong. The gas guage goes way past full when turn the key on, and the pump will run and then shut off, but their is no preasure in the manifold. I can run a hot wire straight to the pump so it will run all the time and it builds pressure op in the manifold but it dont get to the caberator. If I shoot a little either in the carberator it will start untill the either burns out.

Thanks

obee
Was this
answer
helpful?
Yes
No
Friday, August 31st, 2007 AT 12:45 AM
Tiny
SERVICE WRITER
  • EXPERT
In the first post you wrote 3.2, I just wanted to clarify. At the time I made the reply, I couldn't finish my thoughts and just submitted it. I was pretty sure it was just a typo. There are all skill levels that post on the forum and some confuse grand am with grand prix etc. No offense meant.

I agree on the fuel pump, and also think there is a problem with the sending unit..(reostat).

For what it matters. here is the procedure from Mitchell:


http://www.2carpros.com/forum/automotive_pictures/30961_fueltest_1.jpg




http://www.2carpros.com/forum/automotive_pictures/30961_mitchel_4.jpg

Was this
answer
helpful?
Yes
No
Friday, August 31st, 2007 AT 4:40 AM

Please login or register to post a reply.

Recommended Guides