2007 Pontiac Grand Prix Whinning noise when I accelerate

Tiny
BADBADCAR
  • MEMBER
  • 2007 PONTIAC GRAND PRIX
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 63,000 MILES
I took the car to Aamco because mny reg. Mechanic said the noise may be coming from transmission pump. Aamco had the car for a week and said it was the power steering pump and rack and pinion. The noise seemed fainter but is back. Aamco has told me the pump the put in may not be good so I should bring it back. I feel I may be running in circles here it seems no one really knows whats going on with the car while I am possibly paying hand over fist for unnecessary repairs. I ran into some water about a year ago in my car and luckily made it out and had to have the car serviced "dryed out" after wards I am wondering if their was more damage done than was repairs. Please help! Ps my head lamps are also going out on me -justthe dim all other lamos work only dim go out. I have had new bulbs put in but that did not help any. Pontiac is not a friend of mine. For the moment anyhow. :(
Do you
have the same problem?
Yes
No
Thursday, November 19th, 2009 AT 12:15 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
On way to check and see if the PS pump is making the noise is to remove the serp belt. Remove it and start the engine to see if the noise is gone. Only run the engine for a few seconds because it will overheat. Try that to see if the sound goes away. IF it does, then there is a good chance the pump is bad.

Try this and let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Thursday, November 19th, 2009 AT 10:18 PM

Please login or register to post a reply.

Recommended Guides