03 Grand Prix, 3800, 120k miles, Brake lights won't work

Tiny
RICK CHARLES
  • MEMBER
  • 2012 PONTIAC GRAND PRIX
Brake lights won't work, however the upper brake light works fine. All other lights work properly. Replaced bulbs, checked fuses and they're all good. Don't know if one bad socket could cause both lower brake lights to not work. Any help or ideas would be appreciated.
Do you
have the same problem?
Yes
No
Friday, August 31st, 2007 AT 8:05 PM

3 Replies

Tiny
RICK CHARLES
  • MEMBER
I've changed the brake pedal switch, so it's not that, and the bulb socket is getting power when you turn on the headlights. Also, when you fiddle with the hazard light button on the steering column the brake lights flicker. Any ideas?
Was this
answer
helpful?
Yes
No
-1
Friday, August 31st, 2007 AT 11:20 PM
Tiny
MATTT
  • MEMBER
I am having the exact same issue w/ my 01 grand prix. Mine progressed the same to the point where the top light quit too. From what I can see the brake signal feeds through the turn signal switch (the two signals control the same filament). I've got the turn signal swith out and will test tonight.
Was this
answer
helpful?
Yes
No
Wednesday, September 26th, 2007 AT 3:23 PM
Tiny
MATTT
  • MEMBER
Fixed the problem. I took some contact cleaner and sprayed the switch like crazy. Then worked the turn indicator and 4 way flasher about a dozen times. I also had to mess around with the connector on the brake pedal switch, seems like the connection was bad there too.

I'll have to keep an eye on it but seems ok for now. Your issue sound the same, get some zero residue electical contact cleaner (MG Chemicals etc.) And work the 4 way button a few times, the problem might go away.
Was this
answer
helpful?
Yes
No
Thursday, September 27th, 2007 AT 8:00 AM

Please login or register to post a reply.

Recommended Guides