1991 Pontiac Firebird car runs good then doesnt run at all

Tiny
CRYPTICWHITE
  • MEMBER
  • 1991 PONTIAC FIREBIRD
  • V8
  • 2WD
  • MANUAL
  • 250,000 MILES
Ok I was driving it today and it just dropped off to 1000 rpm wouldnt gain speed just kept losing it now when I start it I can get it up past 2000 rpm once and a while but 9 times outa 10 it just dies if you touch the gas its acting like its out of fuel but it has plenty we are thinking that the fuel pressure regulator may be shot and thats whats cousing the problem but not sure any other ideas or does this sound right


now we have replaced the fuel pump tested the map sensor tps and today we pulled off the egr valve one of the ports was plugged with carbon so we cleaned it and put it back on could this be my problem or should I keep digging before I put it together again
Do you
have the same problem?
Yes
No
Tuesday, April 14th, 2009 AT 9:51 PM

8 Replies

Tiny
RASMATAZ
  • MEMBER
Check the fuel pressure this will tell you something about the regulator, filter and fuel pump
Was this
answer
helpful?
Yes
No
Tuesday, April 14th, 2009 AT 10:54 PM
Tiny
CRYPTICWHITE
  • MEMBER
We checked the pressure and the book says 40.5 pounds so we replaced the pump to find out that it was at 37 pounds and needed 34 to 47 pounds to run right gr hasle for nothing lol but edited the upper post with updats any ideas
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 12:03 AM
Tiny
RASMATAZ
  • MEMBER
Check the manifold air temperature sensor, recheck the pressure regulator and ignition timing
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 12:33 PM
Tiny
CRYPTICWHITE
  • MEMBER
Checked and re checked those right now im installing a new ecm ill keep you posted to let you know if thats the problem
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 5:23 PM
Tiny
CRYPTICWHITE
  • MEMBER
Wasnt the computer grrrr
Was this
answer
helpful?
Yes
No
Sunday, April 19th, 2009 AT 8:55 PM
Tiny
RASMATAZ
  • MEMBER
What type of fuel injection system? TBI or MPFI

TBI 9-13psi

MPFI 41-47psi
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 1:47 PM
Tiny
CRYPTICWHITE
  • MEMBER
It is a tpi mpfi I got it some what running now im gona give it a tune up with new plugs wires dist cap and rotar to try and fix the rest of it couse its idleing and just running funny now but it is staying running
Was this
answer
helpful?
Yes
No
Monday, April 20th, 2009 AT 3:51 PM
Tiny
CRYPTICWHITE
  • MEMBER
Ok now I really dont get I the car has new plugs new wires new dis cap and rotar new fuel pump and filter and still has the problem
we thought we had it fixed couse it ran good for 2 days but last night I reved it up in nueltrual and now it starts idels for a half a second and dies same as before but once and a while it will go back to fine again and I can drive around all day it was fine till I reved it in nuetral then it started it again and wont come back from it. Anyway what its doing is
it starts fine runs smooths but dies like it losses spark or gas idk what it could be now when we changed the filter and dis cap it fixed the problems for the time being. But now its the same problem again with it starting fine idleing and dieing then somtimes able to be driven before it dies any idea would really help or if you need any information or and more details please say so this is getting really irritating I keep throwing things at it and nothing is fixing it and for a car I bought almost two weeks ago and only got to drive 3 days and stuck 200 into it so far its getting really depressing
Was this
answer
helpful?
Yes
No
Tuesday, April 21st, 2009 AT 9:12 PM

Please login or register to post a reply.

Recommended Guides