1984 Pontiac Fiero Engine hard to start & will not idle

Tiny
STEVEO1967
  • MEMBER
  • 1984 PONTIAC FIERO
  • 4 CYL
  • 2WD
  • MANUAL
  • 87,000 MILES
Just recently my 1984 Fiero is hard to start and will not idle. I tried to adjust the idle screw but it does not help. I unhooked the MAP sensor and it will idle at a higher speed and the check engine light stays on. Could my MAP sensor be bad? Should I try to plug into the ALDL and see what other codes come up? Could the hard starting and idle problem be related?
Do you
have the same problem?
Yes
No
Thursday, September 4th, 2008 AT 5:20 PM

1 Reply

Tiny
VOODUPUPPY
  • MEMBER
Hi. Sounds like I was having the same issues with my 87 Fiero. Began before Summer. Sometimes wouldn't start. Didn't want to idle (died) at times when I wouldn't be pressing the gas. Check engine light would come on. Etc. Etc. All the fixes you mentioned resulted in not a darn thing. Got so bad it wouldn't idle at all w/o pushing the gas pedal. SO. Come to find out the EGR tube had about a dime sized hole/half-inch crack in it. I have learned this is common problem with the tubes as they easily crack after the wear and tear of years. I took one off my other engine in the garage last night and installed it in my driveable one. All my issues went away exept it is idling somewhat higher than what it should be (about 1200 - 1400 rpm). But at least it IS IDLING! Now it starts w/o problem, stays running when idling, and the 'service engine soon' light doesn't come on. WHO HOO. I sure hope this helps. May not be the problem, but when I was searching on the internet yesterday for help with mine and saw your post I was thinkling. Dang. Sounds like the same issues I'm having. Gotta have some pretty small hands if you want to fix it yourself, though.
Was this
answer
helpful?
Yes
No
Saturday, September 20th, 2008 AT 9:57 AM

Please login or register to post a reply.

Recommended Guides