1995 Plymouth Voyager backup lights fail to work

Tiny
SIXONE1974
  • MEMBER
  • 1995 PLYMOUTH VOYAGER
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 140,000 MILES
I have replaced both backup lights, but they fail to work. All other lights work fine. Could it be the PRNDSL switch on the transmission, or grounding? What should I check? Any suggestions?
Do you
have the same problem?
Yes
No
Wednesday, June 3rd, 2009 AT 2:51 PM

3 Replies

Tiny
JDL
  • EXPERT
Hello, I"m not sure of the litre size of your engine? There may be a back-up lamp relay in the power distribution center under the hood, I'd do some testing at the relay.
Was this
answer
helpful?
Yes
No
+1
Wednesday, June 3rd, 2009 AT 3:14 PM
Tiny
SIXONE1974
  • MEMBER
The engine size is 3.3 L. It is an LE also. This has been an EXCELLENT van. I have owned it since 1998, with about 66000 miles on it then. Changed out the timing chain, radiator, had cracked, and hoses, and new water pump two years ago. Runs like a TOP!

What web site will have a good schematic of the circuit for I can trouble shoot this. I do have a Haynes auto repair manual, but it doesn't go in depth enough.

Thanks for the help
Was this
answer
helpful?
Yes
No
Wednesday, June 3rd, 2009 AT 5:22 PM
Tiny
JDL
  • EXPERT
https://www.2carpros.com/articles/mitchell1eautorepair-car-repair-manuals

Scroll to almost the bottom of the page. It may be the same diagram that is in your book. Anything that is controlled by a relay, I start testing at the relay.
Was this
answer
helpful?
Yes
No
Thursday, June 4th, 2009 AT 8:28 AM

Please login or register to post a reply.

Sponsored links