Engine stalls

Tiny
DEDE121
  • MEMBER
  • 1997 PLYMOUTH BREEZE
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 50,000 MILES
The problem is " engine stalls". Sometimes three times in the same day and other times, it is okay for a couples of days. The gas pressure is good. No code on the scanner. Plugs were change. The gas tank is full or empty it stalls anyway. Whether rains or sunny, does not make a difference. When the car stalls, you start it and it start right away. Do you have a solution?
Thank you
Do you
have the same problem?
Yes
No
Monday, May 5th, 2008 AT 8:01 PM

21 Replies

Tiny
JACK42
  • MEMBER
Try cleaning the Idle Air Control Motor. Also clean out around the butterfly in the throttle bore with carburetor cleaner and a rag. This should help stabilize the idle. Otherwise it may be an Idle Speed Control Motor that is too slow to respond sometimes.
Sometimes the "Coking" gets too thick around the throttle plate and it doesn't let enough air in for the baseline that the computer is supposed to have

See the guide below on "Throttle body service"

https://www.2carpros.com/articles/throttle-actuator-service

Let us know if that fixes it
Was this
answer
helpful?
Yes
No
Tuesday, May 6th, 2008 AT 7:43 AM
Tiny
JAMJ2
  • MEMBER
  • 1997 PLYMOUTH BREEZE
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 124,590 MILES
Engine stalls sometime after being driven a few mile and will not restart just after stalling and then it is time it will start right up and warm up before stalling and does not start immediately afterward.
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Has the check engine light come on? When this happens, have you been able to check for spark and fuel to the engine?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
GRIZZLY269
  • MEMBER
  • 1997 PLYMOUTH BREEZE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 101,000 MILES
My car first started to miss to where I didn't have enough power to go up a slight hill so I took it to a mechanic and they said the coil pack was bad so they replaced it.
It started the same thing over and they said it was the cam sensor so they replaced it.
It started again so they said it is the crank sensor so they replaced it.
Now it is doing the same thing and they told me it is the PCM module but the codes read the coil and o2 sensor is bad.
What should I replace this time?
Thank you, Ed
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
For a start get the fuel pressure check and have the exhaust system checked for restriction then get the coil /O2 sensor tested.
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
LEOPOET
  • MEMBER
  • 1997 PLYMOUTH BREEZE
  • 4 CYL
Okay, I was driving to the local store around the corner and I was waiting to go into the driveway of the store because there was someone else in front of me waiting to get in as well. So as I am about to pull in the car completely shut off. Now I have put oil in the tank as well as gas. Plus the check engine light is on. Please help
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
You put oil in the tank? The fuel tank? Have you checked for spark and fuel to the engine? Have you scanned the computer to see what code is stored in the system?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
TONYSAP
  • MEMBER
  • 1997 PLYMOUTH BREEZE
Four cylinder front wheel drive 110,000 miles.

Engine stalls when put in reverse or drive, never stalls at highway speeds only at idle) ASD relay drops out, no codes set, no check engine light also(pulled MAP/temperature sensor, got check engine light and two codes). So it is okay. You can get it to start buy removing both connectors from Engine brain (I checked codes before doing this) or it will start perfectly after 20 Minutes. Fuel pump coil, ASD relay are new. Car runs perfectly other wise. Can crank or camshaft sensor (pro bally crankshaft) and shuts down engine computer without setting a code.110,000 miles. 2.0 L auto
Any help would be appreciated
1-30-08
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:33 PM (Merged)
Tiny
JACK42
  • MEMBER
Yes, a sensor can do that, if the PCM does not see enough failures it will not set the code. Does it shut down or idle down? Did you say that the ASD relay is shutting down?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
2CARPROS-ARCHIVES
  • MEMBER
  • 1997 PLYMOUTH BREEZE
  • 1,000 MILES
What can make a car cut off when you make a turn?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
JACOBANDNICKOLAS
  • EXPERT
Does it happen when your foot is on the gas or only when it is at an idle? If an idle, check for vacuum leaks and check the idle air control valve. If it is happening when your foot is on the gas, check to make sure the fuel pump pressure is within the manufacturer's specs.
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
KATIELYNN
  • MEMBER
  • 1998 PLYMOUTH BREEZE
I have an Expresso 2.4. Recently the air conditioning went out. It would blow hot air. I bought refrigerant and that did not help. I stopped using the AC. About two days later I noticed a funny smell as I was half a mile from home. I pulled into the driveway and when I shut the car off I noticed smoke coming from under the hood. It was coming from the passenger side of the car. I turned the car off. When I try to start it now it has difficulty starting and squeals very high pitched, and then shuts off after about 20 seconds. Any clue what this could be and how much it may cost? Thanks!
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
JENNIFER4317
  • MEMBER
I have this same problem so can anyone help us?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
TOMMCEWEN@HOTMAIL.COM
  • MEMBER
  • 1996 PLYMOUTH BREEZE
Four cylinder two wheel drive manual.

What causes the engine to shut off just prior to stopping or when I decelerate and push in the clutch. It will not idle until the engine temperature rises. Idle rpm's are at 750, it seems to be heat sensitive because it does not shut off in summertime temperatures. The thermostat has been changed. Thanks
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
MERLIN2021
  • EXPERT
If it is more temperature related check/replace the ECT(engine coolant temperature) sensor near the thermostat housing. The IAC(idle air control) can do the same thing, but will do it hot or cold.


http://www.2carpros.com/forum/automotive_pictures/62217_ect_Breeze_1.jpg



http://www.2carpros.com/forum/automotive_pictures/62217_iac_2.jpg

Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
MARCIE1813
  • MEMBER
  • 1998 PLYMOUTH BREEZE
Four cylinder two wheel drive automatic.

Hello, just replace valves and gaskets, took for smog, everything running great. No codes. Then my stepfather ran it out of gas. Put gas into the car, check engine light staying on and wants to shut off while driving. Just replace fuel filter since car had been sitting with old gas for about two years. What could be the reason why check engine light on now?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
BMRFIXIT
  • EXPERT
The codes should point to the troubled area.
Cycle key on off on off on read codes in odometer area
or check engine will flash codes (* ** code 12 ).
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
MANDERS42
  • MEMBER
  • 1999 PLYMOUTH BREEZE
  • 130,000 MILES
I have a 2.4. It broke a timing belt. Replaced seals, belt, accessory belts, and water pump. Timing is correct. Car started but had to flutter the gas to get it to start. It runs, but idles rough, once you drive it and the car warms up it will shut off every time it is stopped and gets harder and harder to start. Cleaned PCV valve. Tried again and it did not fix the problem. It runs fine just shuts off every time it stops. Can anyone help?
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
CADIEMAN
  • MEMBER
Check the fuel pump pressure with a gauge.
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)
Tiny
CARADIODOC
  • EXPERT
The 2.4L is an "interference" engine. It is going to have bent valves when the timing belt breaks. A compression test may show low compression, but a cylinder leakage test will allow you to identify which valves are leaking. The fact the engine started and runs at all is just good fortune. Bent valves explains the rough idle.

Most likely you disconnected the battery to perform this service. If so, the Engine Computer lost its memory and has to relearn "minimum throttle" before it will know when it must be in control of idle speed. It also might not give you the normal "idle flare-up" to 1500 rpm when you start the engine, and it will stall at stop signs. To meet the conditions for the relearn to take place, drive at highway speed with the engine warmed up, then coast for at least seven seconds without touching the brake or gas pedals.
Was this
answer
helpful?
Yes
No
Friday, September 28th, 2018 AT 5:34 PM (Merged)

Please login or register to post a reply.

Recommended Guides