Code P0341

Tiny
BOSSOFALLBOSSES1987
  • MEMBER
  • 2007 SATURN OUTLOOK
  • 3.6L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 180,000 MILES
Car starts just fine but has a rattle noise whenever accelerate and code pop up P0341 Saturn - Camshaft Position Sensor 'A' Circuit Range/Performance -- Possible causes: - Faulty Camshaft Position Sensor - Camshaft Position Sensor harness is open or shorted - Camshaft Position Sensor circuit poor electrical connection - Faulty starter motor - Starting system circuit - Dead (weak) battery I've changed the sensor but still same issue I've tested the connector its getting power and ground and a 5 volt signal. What else should I check? The check engine light always on before start the car but goes off after car is running. But whenever I check for codes with scanner it's no code stored, but p0341 pops up under pending codes. Whenever I clear code and turn car off the check engine pops right back on even though there's no code stored in ECU.
Do you
have the same problem?
Yes
No
Wednesday, November 6th, 2019 AT 12:54 PM

6 Replies

Tiny
SCGRANTURISMO
  • EXPERT
Hello,

There are two different types of Direct Trouble Codes [DTC][s] and when they illuminate the Malfunction Indicator Lamp [MIL] or "check engine" light. Some DTC's are 1 trip DTC's and some are 2 trip DTC's, and are programmed into your vehicle's Power-train Control Module [PCM] or "computer". DTC P0341 is a two trip DTC, so after 1 trip it will store in your vehicle's PCM as pending until the second trip is taken, at which time it will move from pending to permanent. In the diagrams down below I have included the diagnostic troubleshooting guide from the vehicle manufacturer on DTC P0341 for your vehicle. Please go through this guide and get back to us with how everything turns out.

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
Thursday, November 7th, 2019 AT 12:23 PM
Tiny
BOSSOFALLBOSSES1987
  • MEMBER
Which sensor is CMP on bank 1?
Was this
answer
helpful?
Yes
No
Sunday, November 10th, 2019 AT 9:24 AM
Tiny
DL AUTOSHOP
  • MEMBER
Hello,

I've attached a picture below showing the camshaft position sensor for bank 1. I've circled it in red as #2. Here is a quick basic tutorial showing how to remove/replace a camshaft sensor:

https://www.2carpros.com/articles/camshaft-angle-sensor-replacement

Hope this helps and thanks again for using 2CarPros.

Danny-
Was this
answer
helpful?
Yes
No
Sunday, November 10th, 2019 AT 7:56 PM
Tiny
BOSSOFALLBOSSES1987
  • MEMBER
Thanks. I've replaced the sensor problem still there. I think it could be a wiring problem, but I am not really good with wiring. But I did check the two outside wires on the connector it showed 4.95v.
Was this
answer
helpful?
Yes
No
Monday, November 11th, 2019 AT 2:00 AM
Tiny
BOSSOFALLBOSSES1987
  • MEMBER
Rattle noise with p0341.
Was this
answer
helpful?
Yes
No
Monday, November 11th, 2019 AT 5:00 AM
Tiny
KEN L
  • ADMIN
Thanks for the video. It sounds like the engine is having an issue like a small piece of carbon is stuck in a combustion chamber. I would have a decarbon process done to see if that helps. If not it can be a cracked crankshaft or seized piston wrist pin/broken piston. This can be difficult to find without a tear down.
Was this
answer
helpful?
Yes
No
Wednesday, November 13th, 2019 AT 10:11 AM

Please login or register to post a reply.

Sponsored links