P0017 code will not clear

Tiny
LBENTON12
  • MEMBER
  • 2014 CHEVROLET MALIBU
  • 2.5L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 95,000 MILES
I'm trying hard to avoid a high price tag here with mechanics I don't know if I can trust.

Replaced the 2 cam actuators on top, the 02 sensor, and crankshaft position sensor. All at different times and in that order. After the CPS replaced, tried doing relearn and it wouldn't run it nor would it clear the code any way tried. It keeps coming back after starting the car.

I'm going through checking wires noticed oil in the connector to the exhaust cam actuator. I don't think it should be there, right? Could this be causing the code?
Do you
have the same problem?
Yes
No
Monday, November 25th, 2019 AT 8:44 AM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Good morning,

Yes, it could. Clean the connector out of all fluid and retry.

The most common reason for this is dirty oil holding the actuator open.

I would have the oil system flushed out for all dirt and debris. This is not an oil change, it is a system power flush which gets into all the passages.

Was there any other code besides the 17?

Roy
Was this
answer
helpful?
Yes
No
Monday, November 25th, 2019 AT 8:58 AM
Tiny
LBENTON12
  • MEMBER
No other codes now. Before there was P0013, P0014 that went away after actuators replaced.

I will try the cleaning and flush. Thanks so much!
Was this
answer
helpful?
Yes
No
Monday, November 25th, 2019 AT 9:07 AM
Tiny
ASEMASTER6371
  • EXPERT
You are welcome.

Always glad to help.

Roy
Was this
answer
helpful?
Yes
No
Monday, November 25th, 2019 AT 9:09 AM

Please login or register to post a reply.

Recommended Guides