Only part of my main fuse box is getting power?

Tiny
KYLE HOBEN
  • MEMBER
  • 2012 GMC ACADIA
  • 212,000 MILES
Replaced evaporator core and went to start car and have zero power. Checked battery and it's good. Put tester on fuses under hood and only part is getting power to them and of course one of them that is not getting power is ECM.
Monday, August 22nd, 2022 AT 12:23 PM

9 Replies

Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,590 POSTS
When you did the Evap code there are grounds you had to disconnect did you reinstall them? If so, there is a main electrical connector that doesn't sound like it is plugged in completely. Is the BCM plugged in also give me 3 fuses that aren't working so can look up where they get power from, please.
Was this
answer
helpful?
Yes
No
Monday, August 22nd, 2022 AT 5:26 PM
Tiny
KYLE HOBEN
  • MEMBER
  • 5 POSTS
I plugged all connectors back in and even triple checked. Three of the fuses with no power are Emission 1, Even coils and ECM 1.
Was this
answer
helpful?
Yes
No
Tuesday, August 23rd, 2022 AT 3:12 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,590 POSTS
Okay, thanks. There is a powertrain relay (PWR TRN) that needs to be replaced which powers these fuses. Here is the location in the under-hood fuse panel so you can change it out and fix the problem. Check out the diagrams (below). Please let us know what happens.
Was this
answer
helpful?
Yes
No
Wednesday, August 24th, 2022 AT 9:23 AM
Tiny
KYLE HOBEN
  • MEMBER
  • 5 POSTS
I switched relay with another relay from the box and nothing changed. I don't see multiple relays going bad at the same time.
Was this
answer
helpful?
Yes
No
Wednesday, August 24th, 2022 AT 1:21 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,590 POSTS
This leaves the ground and connectors under the dash that you removed. I would go back over the job to see if you left anything off or disconnected.
Was this
answer
helpful?
Yes
No
Thursday, August 25th, 2022 AT 5:01 PM
Tiny
KYLE HOBEN
  • MEMBER
  • 5 POSTS
I took it all back off and checked all connectors. There were no ground wires besides those in the connectors. It doesn't have any wires grounded to the body behind the dash. Any idea which connector or ground wire I should be looking for to explain my fuses not getting power? I can write down every fuse with power and without if that will help.
Was this
answer
helpful?
Yes
No
Thursday, August 25th, 2022 AT 5:07 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,590 POSTS
Yes, if you can just tell me a few fuses that don't have power I can look it up.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2022 AT 12:16 PM
Tiny
KYLE HOBEN
  • MEMBER
  • 5 POSTS
You need three more fuses that don't have power aside from the three I already told you? Just wanting to clear that up.
Was this
answer
helpful?
Yes
No
Friday, August 26th, 2022 AT 12:28 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,590 POSTS
Yes, please tell me the other fuses that are not working. Do you have power at terminal 30 of the powertrain relay?
Was this
answer
helpful?
Yes
No
Saturday, August 27th, 2022 AT 11:51 AM

Please login or register to post a reply.

Sponsored links