2001 Oldsmobile Silhouette problem with turn signals


Electrical problem
2001 Oldsmobile Silhouette 6 cyl Front Wheel Drive Automatic 149000 miles

My 2001 Oldsmobile is having trouble with the indicator lights. Here are the symptoms; When applying the brakes, the turn signals both glow faintly. When you turn on the left blinker it works fine when not breaking. When applying the brakes, it blinks at double speed AND the turn indicator at rear alternates flashing with the tail light. This alternating flashing does not happen on the passenger side. Also, with the left blinker flashing, the right blinker stops glowing when applying the brakes. With the right blinker on and applying the brakes, the left side indicator illuminates brightly, but not flashing. It glows constant until letting off brake pedal. And finally the left side backup light glows faint with brakes applied, then in reverse gear it glows bright, but the break light goes off.

If it means anything, about a month ago, I sliced into the left rear lights to hook up a trailer harness. Everything was fine until recently. I HAVE changed all 4 bulbs in rear left light assembly. Thanks!

Do you
have the same problem?
Monday, November 17th, 2008 AT 5:36 PM

1 Reply


Hello -

I would start with the splicing. It appears that something is touching or shorting out. I would recheck the wiring. If you cannot find the problem then totally disconnect what you have done and make sure all wires are okay and the system is working fine. Then go one by one to wire ensuring no bare wires are touching each other and grounding out.

Was this
Monday, November 17th, 2008 AT 5:47 PM

Please login or register to post a reply.

Recommended Guides