1999 Oldsmobile Silhouette does not shift into upper gears

Tiny
SWEDONE10
  • MEMBER
  • 1999 OLDSMOBILE SILHOUETTE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 200,100 MILES
The problem appears after the transmission warms up. We drained part of the fluid out due to being too full. I added new high mileage fluid. This appeared to help but the problem still is occurring.
It shift fine in the morning and sometime the first part of the day. I drive for a living and drive an average of 200 miles a day. All highway pretty much. But if I slow down and do not come to a complete stop then the transmission goes into the "quick shift mode" and the transmission appears to "wine" as it shifts through the gears. If I stop and let the van sit then it sometimes goes back to normal shifting. One mech said if it shifts at all its not " A bad trans", but something internally or electrical is occurring.
Can you give some Ideas.
Thanks
Do you
have the same problem?
Yes
No
Monday, April 5th, 2010 AT 6:03 AM

1 Reply

Tiny
JACK42
  • MEMBER
Has it ever set a check engine light when it is shifting weird?If it was something computer controlled it would have set a light when it was misbehaving. Since temp changes things, I would lean towards possibly a bad seal or solenoid in the trans and when the fluid thins out from being hot, it isnt able to hold pressure. Have the PCM scanned for trans codes first to see if anything has been stored in the memory
Was this
answer
helpful?
Yes
No
Thursday, April 8th, 2010 AT 7:51 AM

Please login or register to post a reply.

Recommended Guides