Charge system problems

Tiny
JULIE HOGAN
  • MEMBER
  • OLDSMOBILE
1997 Old. Aurora 73.264 miles, 8 cyclinder

While driving my car, battery symbol lights up and the "check charging system" warning is displayed, car became very sluggish, lost all power to accesories then car barely went 5 mph. I pulled over, it died.
Mechanic replaced alternator (2nd time alternator was replaed in two year span). Car ran great for two weeks then same problem occured.
I don't think the alterator or the battery is bad. I have very little finances, don't want to keep paying for repairs that arent' working?
The battery, alterator, serpentine belt are all brand new.
Do you
have the same problem?
Yes
No
Monday, August 6th, 2007 AT 8:25 AM

7 Replies

Tiny
SERVICE WRITER
  • EXPERT
Alternaters and starter that have been remanufactured are possibly the worst offenders for dependabilty. Take it back to the shop that did the alternater and ask them to re-check it. There are some brands I have quit using because of the high failure rate.

All of the battery cables should be clean and tight also.
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 8:34 AM
Tiny
JULIE HOGAN
  • MEMBER
GOOD NEWS! I took my car back to the mechanic, he said it was a bolt holding a wire to the alternator, they put a new bolt on and the car runs great. NO CHARGE.
Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 12:52 PM
Tiny
SERVICE WRITER
  • EXPERT
Your welcome. If that was what you meant.
Was this
answer
helpful?
Yes
No
Tuesday, August 7th, 2007 AT 1:15 PM
Tiny
JULIE HOGAN
  • MEMBER
Excuse my poor manners!

Thank You Very much for your reply.
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2007 AT 2:34 PM
Tiny
SERVICE WRITER
  • EXPERT
No problem, I was just missin' the lovin' :wink:
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2007 AT 6:05 PM
Tiny
SUPERDUPERDVD
  • MEMBER
Julie,
I have a 1997 Aurora with 94,000 miles, and the alternator failed on mine also. I took it to a repair shop with a "lifetime waranty" alternator, and they replaced it for me. Fixed the problem for 100 miles, and it failed again. They replaced it again, this time the new alternator lasted 250 miles, now same problem. I am taking it to a different shop that specializes in electrical and have them look at it. Seems hard to believe I got 2 bad alternators in a row, plus it isn't cheap to get them installed.
Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2007 AT 11:53 AM
Tiny
SERVICE WRITER
  • EXPERT
Not at all hard to understand to me. There are some rebuilt alternaters and starters that suck. And they are usually problems with the same stock numbers. Lifetime is not always quality.
Was this
answer
helpful?
Yes
No
Wednesday, September 12th, 2007 AT 1:45 PM

Please login or register to post a reply.

Recommended Guides