2001 Other Oldsmobile Models 2001 OLDS SILHOUETE IDLE?

Tiny
BMAX100
  • MEMBER
  • 2001 OLDSMOBILE
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 83,000 MILES
HI, I have a problem with my van. When I take off and go like 40 to 50mph and let go of the gas pedal, the van still stays at that speed, unless I apply the brakes, then it takes a little longer to stop. Also, if i'm in a dead stop, and not pressing the gas pedal, the van slowly goes to 30mph, by itself. Other than that, the engine runs perfect, even when in park. I wanted to know if anybody knows what the problem could be? I would appreciate any kind help on this. Thanks.
Do you
have the same problem?
Yes
No
Friday, April 25th, 2008 AT 9:13 PM

6 Replies

Tiny
LEGITIMATE007
  • EXPERT
Sounds like your cruise control is acting up. Take a look and make sure its off
Was this
answer
helpful?
Yes
No
Friday, April 25th, 2008 AT 9:27 PM
Tiny
BMAX100
  • MEMBER
It's off, and it still does it.
Was this
answer
helpful?
Yes
No
Friday, April 25th, 2008 AT 9:35 PM
Tiny
LEGITIMATE007
  • EXPERT
You have to check it underneath the hood in the engine compartment. It may be stuck
Was this
answer
helpful?
Yes
No
Friday, April 25th, 2008 AT 10:12 PM
Tiny
BMAX100
  • MEMBER
Doesn't the cruise control, kick on a certain speed? Also, how can I tell if it's stuck? Thanks.
Was this
answer
helpful?
Yes
No
Friday, April 25th, 2008 AT 10:17 PM
Tiny
RASMATAZ
  • MEMBER
The cruise control has to be set to activate it. Find the fuse no.739 10amp in the instrument panel fuse block and remove it this will make it inoperable and see what happens

Could also be the throttle position sensor way out of calibration fooling the computer that the engine needs fuel when not needed.


http://www.2carpros.com/forum/automotive_pictures/12900_cruise_1.jpg

Was this
answer
helpful?
Yes
No
Saturday, April 26th, 2008 AT 1:07 AM
Tiny
BMAX100
  • MEMBER
Hi, Thank you for your kind help. One thing I forgot to mention is, when I bought the vehicle yesterday, it was running with the low fuel light on, for about 20mins. We put gas and then drove on the highway to go home, we turned the cruise control on, it worked. Then after 30mins of highway driving, we came to city limits, which was 45mph or less. Then this started happening. I am disabled, with a leg injury, and I live on limited income, and if I take it to a dealership, they might start guessing, and charge me with parts, not needed to be fixed. I would appreciate kindly, if you can help me with this problem. Thank you, again.
Was this
answer
helpful?
Yes
No
Saturday, April 26th, 2008 AT 2:01 AM

Please login or register to post a reply.

Recommended Guides