1990 Other Oldsmobile Models Help needed with my olds please

Tiny
GMDEMO06
  • MEMBER
  • 1990 OLDSMOBILE
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 20,000 MILES
I have a 1990 old calais with a 2.5 4 banger in it, it's my winter bomb for the last 2 winters. I went friday and had the emissions test done to re new the plates. The guy doing the test said the car passed better then most newer cars. Anyways I left there and drove 3-4 miles and then it started missing and acting strange. I thought maybe there was some water in the fuel freezing it up so I poured in a container of gas line antifreeze and added 10 bucks worth of high grade gas. I babied it home. When it's in parked you can mash the gas to the floor with no problems but when you put it in gear and put a load on it it starts missing and back firing thru the top of the engine. I thought maybe a plug or wire went for a crap so I put new plugs and wires on the car and the same thing. What could be wrong?
Do you
have the same problem?
Yes
No
Saturday, December 15th, 2007 AT 11:37 AM

3 Replies

Tiny
MERLIN2021
  • EXPERT
Pressure test the fuel pump. Sounds like either gas starvation, or timing belt, except it runs OK without a load.
Was this
answer
helpful?
Yes
No
Saturday, December 15th, 2007 AT 11:44 AM
Tiny
GMDEMO06
  • MEMBER
Its not the timing belt. Can you tell me how to test for FP. I can get a tester if you could help me that would be good.
Was this
answer
helpful?
Yes
No
Saturday, December 15th, 2007 AT 3:49 PM
Tiny
MERLIN2021
  • EXPERT
http://www.2carpros.com/forum/1998-chevy-blazer-fuel-pump-vt77850.html?highlight=
Not sure about your wire colors...
Was this
answer
helpful?
Yes
No
Sunday, December 16th, 2007 AT 6:33 AM

Please login or register to post a reply.

Recommended Guides