1999 Oldsmobile Intrigue Transmission not shifting properly

Tiny
HEALTHNUT101
  • MEMBER
  • 1999 OLDSMOBILE INTRIGUE
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 179,000 MILES
I got this car about 2 years ago and ever since I got it there is a humming or buzzing noise that occurs when I accelerate. This noise does not happen when decelerating or coasting just when I accelerate and it sounds like it is coming from the transmission.

The other problem I have is that the transmission shifts smooth sometimes but every once and a while it will start shifting very harshly, to the point where it jerks the entire car. I have gotten a trasnsmission flush, and the fluid is at the proper level.

I am in the process of ordering a speed control sensor to see if that may be the issue with the late shifting, and harsh shifting problems. This still however leaves the buzzing noise in the tranny when accelerating.

Any help on this issue would be greatly appreciated, thank you very much and have a great day
Do you
have the same problem?
Yes
No
Tuesday, May 5th, 2009 AT 9:25 AM

2 Replies

Tiny
DOCFIXIT
  • EXPERT
Hi
Problem maybe with Pressure Control Solenoid if contamination has gooten to it it may buzz and will cause harsh shift. Need to have trans pressures checked.
Hope this helps
Thanks for donate
Was this
answer
helpful?
Yes
No
-1
Tuesday, May 5th, 2009 AT 10:51 AM
Tiny
CARSANDAIRPLANES
  • MEMBER
Yes, contamination in your Pressure Control Solenoid (or elsewhere in the valve-body) is likely causing your problems. The reason the noise is not present when you coast is because the input sprag gear (which works like a ratchet) is doing its job.
Was this
answer
helpful?
Yes
No
Saturday, March 13th, 2010 AT 10:40 PM

Please login or register to post a reply.

Recommended Guides