1995 Oldsmobile Ciera Blower will not run on the high setti

Tiny
CESTUS
  • MEMBER
  • 1995 OLDSMOBILE CIERA
Electrical problem
1995 Oldsmobile Ciera 6 cyl Automatic 158000 miles

Hi all I have got a 1995 Oldsmobile Ciera V6 158k and the blower motor will not work on the high setting. It works fine on all other settings except the high setting. When switched to the high setting the blower motor will stop blowing air, but the A/C compressor is still working.

I have replaced the blower motor resistor with a new one and still that did not fix it, what do you think could be the problem a new blower.
Do you
have the same problem?
Yes
No
Friday, June 18th, 2010 AT 7:31 AM

5 Replies

Tiny
RASMATAZ
  • MEMBER
Hi Cestus, Welcome to 2carpros and TY for the donation

Lets try swapping the blower motor relay or replace it the relay powers the hi setting
Was this
answer
helpful?
Yes
No
Friday, June 18th, 2010 AT 9:16 AM
Tiny
CESTUS
  • MEMBER
OK, where is the blower motor relay located underhood or dash?
Was this
answer
helpful?
Yes
No
Friday, June 18th, 2010 AT 3:27 PM
Tiny
RASMATAZ
  • MEMBER
Its on the relay bracket in right front corner of engine compartment
Was this
answer
helpful?
Yes
No
Friday, June 18th, 2010 AT 3:39 PM
Tiny
CESTUS
  • MEMBER
OK I located 5 relays on the bracket two of them were 5 pronged (the new relay is also 5 pronged) I swapped them both out at different times with the new relay neither worked the blower motor still does not work on high speed.

Please advise.
Was this
answer
helpful?
Yes
No
Saturday, June 19th, 2010 AT 9:08 AM
Tiny
RASMATAZ
  • MEMBER
Okay check the orange wire on the blower relay for continuity back to the high setting contact of the blower switch


http://www.2carpros.com/forum/automotive_pictures/12900_blower_relay_8.jpg

Was this
answer
helpful?
Yes
No
Saturday, June 19th, 2010 AT 3:12 PM

Please login or register to post a reply.

Recommended Guides