2001 Oldsmobile Bravada cooling problem

Tiny
HOTENGINE778
  • MEMBER
  • 2001 OLDSMOBILE BRAVADA
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 128,000 MILES
Ok thanks to Bob, Ken, all of the 2CarPros team
and legitimate007, Certified 2CarPros Technician
but I still have the enging running hot - I was told by a mechanic that I should change the radiator cap because it was preventing the flow of coolant. The car temperature runs at about 220. And when you open the hood it is very hot under the car. There are no leaks anywhere. This all started after my oil change at EZ Lube.
Note: 1. Can a thermostat and water pump go at the same time?
also 2. If there is a small leak in the intake manifold can stop leak help that issue

will replacing or removing the thermostat solve the running hot problem?

thanks so much
Do you
have the same problem?
Yes
No
Wednesday, March 31st, 2010 AT 4:53 PM

19 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
I'm just getting involved with this. First, two things can go bad at the same time. As far as the thermostat, if you haven't replaced it, try a new one. It may help.

As far as the leak, I don't recommend using a sealant as you described. They sometimes work in the radiator, but the intake is different.

Let me know when the car heats up, has the radiator been flushed, and have you checked to make sure the coolant is staying full?
Was this
answer
helpful?
Yes
No
Friday, April 9th, 2010 AT 7:53 AM
Tiny
HOTENGINE778
  • MEMBER
Thanxs
Was this
answer
helpful?
Yes
No
Saturday, April 10th, 2010 AT 11:28 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Glad to help. Let me know what you find and we'll go from there.

Joe
Was this
answer
helpful?
Yes
No
Saturday, April 10th, 2010 AT 11:16 PM
Tiny
HOTENGINE778
  • MEMBER
I drove it around about 2 hours stop and go on saturday, errands etc. Maybe total of 9, 10 miles and 2 different people looked at the car

1st one said:

I was told that this would solve problem

1 front crankshaft seal 2 intake manifold corner to seal - to use
seal tabs

how does a crankshaft seal get broken - I believe that it happpened at EZ Lube

also where do I check the oil level to refill for the oil if I am supposedly loosing it thru the front crankshaft broken seal because my oil pan is slightly moist with oil and it's not coming from the oil pan

oh I also check the engine oil and saw some very faint white smoke when I first pulled out the dipstick

2. The second guy said

as far as the leak the pressure was ok a guy did a visual and touched the upper hose that runs near the thermostat and said that there are no leaks looking at it from the top of the car

what do you guys think
Was this
answer
helpful?
Yes
No
Sunday, April 11th, 2010 AT 4:24 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Wow! If two people said something to you, there must be a lot of smoke. As far as a crank seal, you would see it leaning at the front of the oil pan.

I have to ask because I'm a little confused. When you open the hood, does it smell like oil burning or coolant? As far as the slight steam from the dip stick, that isn't out or the ordinary. Also, that is where you would check all motor oil for the engine. If the crank seal is leaking that bad, you would notice the oil level going down.

Let me know about the smell. Also, when you checked the oil, did it have a creamy white look to it?

LEt me know.

Joe
Was this
answer
helpful?
Yes
No
Sunday, April 11th, 2010 AT 10:06 PM
Tiny
HOTENGINE778
  • MEMBER
Ok yes the oil pan is moist
where is the front crank shaft located and
can I do it myself and how much does it cost
also:
how does a crankshaft seal get broken - I believe that it happpened at EZ Lube - I heard to loud cranking noises when they were working on the oil change coming from the bottom of the car

the oil that the car has is 10 30
it does not have an oil smell to it
and no creamy whiite look

yes it does have a coolant smell when I open the hood but the coolant level does not drop - it stays the same - It seems to weep from a very distinct place - still unknown
Was this
answer
helpful?
Yes
No
Monday, April 12th, 2010 AT 12:19 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0604_1.jpg



take a look
Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:28 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0613_1.jpg



hotengine778
Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:31 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0612_1.jpg



top view
Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:34 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0608_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:37 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT06092_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:39 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0622_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:41 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0606_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:43 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0605_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:45 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT06072_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:47 PM
Tiny
HOTENGINE778
  • MEMBER


http://www.2carpros.com/forum/automotive_pictures/508831_PICT0617_1.jpg

Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:53 PM
Tiny
HOTENGINE778
  • MEMBER
Here above are pictures of under the car - places that I have seen wet, moist or run a paper towel and it has come out wet n dirty - much help is appreciated
Was this
answer
helpful?
Yes
No
Friday, April 16th, 2010 AT 5:55 PM
Tiny
HOTENGINE778
  • MEMBER
This friday 4/16 morning the car seems to run fine when I first start it in this morning afterwards about 2 hours of driving stop n go for errands about (10 miles total)it gets sluggish, looses horsepower when I go from 0 to about 20, engine sounds rough and it has slight hesitation so I parked it and waited about 45 minutes and drove it around again added some more gas in the tank and drove it home, fine. This morning saturday 4/17, it started fine again - what can be the cause of this problem - (sluggish, looses horsepower when I go from 0 to about 20, engine sounds rough and it has slight hesitation)
Was this
answer
helpful?
Yes
No
Saturday, April 17th, 2010 AT 1:04 PM
Tiny
HOTENGINE778
  • MEMBER
It got put on the OBDII

got these trouble codes:

p0300 random/multiple misfire detected
p0405 exhaust gas regulator sensor A CKT low
p0410 Secondary air injection system malfunction

can I do it myslef and how much will it cost
need a little assistance thanks guys your the best!
Was this
answer
helpful?
Yes
No
Saturday, April 24th, 2010 AT 6:10 PM

Please login or register to post a reply.

Recommended Guides