1997 Oldsmobile Aurora Catalytic convertor codes will not c

Tiny
DPN1460
  • 1997 OLDSMOBILE AURORA

Computer problem
1997 Oldsmobile Aurora V8 Front Wheel Drive Automatic 135000 miles

convertor replaced at 110,000 and o2 sensors, code cleared for 150 miles and returned. Replaced convertor and used different sensors, code does not clear. Car runs great but the light is annoying.

Do you
have the same problem?
Yes
No
Monday, October 4th, 2010 AT 4:51 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,398 POSTS

What code are you getting?

Was this
answer
helpful?
Yes
No
Monday, October 25th, 2010 AT 9:57 PM
Tiny
DPN1460
  • MEMBER

P420, any help will be appreciated.

Was this
answer
helpful?
Yes
No
Thursday, October 28th, 2010 AT 2:52 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,398 POSTS

A PO420 is a generic fault code indicating a drop in converter efficiency. I realize you replaced the converter and O2 sensors. Did you check to make sure the sensors are switching between a rich.08 and a lean.03 voltage shortly after starting the vehicle. If there is no change (flat line) you have a bad sensor. Most times a bad sensor will set a sensor code and not the converter. However, I have seen situation where the sensors are good enough to prevent the 02 code but bad enough to set a PO420. Also, is the converter new? Were the sensors you used new? Is the converter OBD2 complient?

Let me know

Was this
answer
helpful?
Yes
No
Thursday, October 28th, 2010 AT 8:55 PM

Please login or register to post a reply.

Other Catalytic Converter Replace/Remove Questions