ENGINE PERFORMANCE PROBLEM1994 OLDSMOBILE ...

1994 Oldsmobile Achieva

Tiny

dumcheesemonkey

March, 31, 2009 AT 8:58 PM

Engine Performance problem
1994 Oldsmobile Achieva 4 cyl Two Wheel Drive Automatic 69k miles

My car had been kind of sputtering for a couple months on highway trips but we kind of ignored it. While driving one day it got real bad, when I would hit the gas half the time it felt like it was going into neutral. But it eventually died at a light. I towed it home and it would start but wont idle. It sputtered and died. Ive since put on a fuel filter (was told it could fix). Now it will run but if I let off the gas itll die. And while its running it sputters a lot kind of sounding like a lawnmower. I was told it could b something with timing. I have no idea what im doing.

FOUND 1294 RELATED QUESTIONS

Dies On Idle

22 ANSWERS
8 IMAGES

3 Answers

Tiny

Jacobandnickolas

August, 20, 2009 AT 3:55 PM

Has the check engine light come on? Have you checked fuel pump pressure? Also, this could deal with a clogged catylatic converter. Have you checked these things? Do you need directions?

Tiny

chugjam

September, 22, 2009 AT 8:44 AM

Please inform me of any ideas that you may have concerning this issue. I have the same malfunction with my car.

Tiny

Jacobandnickolas

September, 22, 2009 AT 10:14 AM

I would start with the same questions. Have any of them happened to you?

Please login or register to post a reply.

Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet
Fuel Pump Replacement Ford Mustang
Fuel Pump Replacement
Fuel Pump Replacement Done Right