Truck started shifting funny no forward movement Od off light flashing and transmission fault light on

Tiny
JIMMY MEADE
  • MEMBER
  • 2005 FORD F-150
  • 5.4L
  • V8
  • 4WD
  • AUTOMATIC
  • 240,000 MILES
Truck started shifting funny then get no forward movement without it revving high. Codes p0720 and p2160 also a p2198. Changed OSS wiring looks good except for two pinches at connector cleared all codes, but problem is still there.
Do you
have the same problem?
Yes
No
Tuesday, September 20th, 2016 AT 7:13 AM

7 Replies

Tiny
KEN L
  • ADMIN
Yes it will give the OSS code when the input shaft and out put shaft do not match when the transmission is slipping, it might be time for a rebuild.

Please let us know what you find so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
Saturday, September 24th, 2016 AT 4:37 PM
Tiny
JIMMY MEADE
  • MEMBER
So the input sensor could be faulty
Was this
answer
helpful?
Yes
No
Sunday, September 25th, 2016 AT 2:40 PM
Tiny
KEN L
  • ADMIN
Yes is could, I would, sorry I though you changed that already. Try that first
Was this
answer
helpful?
Yes
No
Sunday, September 25th, 2016 AT 3:18 PM
Tiny
JIMMY MEADE
  • MEMBER
Only changed ouput sensor
Was this
answer
helpful?
Yes
No
Monday, September 26th, 2016 AT 5:42 AM
Tiny
KEN L
  • ADMIN
You changed it and it helped or?
Was this
answer
helpful?
Yes
No
Monday, September 26th, 2016 AT 9:39 AM
Tiny
JIMMY MEADE
  • MEMBER
Nothing happen still the same reverse loads up no problem
Was this
answer
helpful?
Yes
No
Monday, September 26th, 2016 AT 12:52 PM
Tiny
KEN L
  • ADMIN
It sounds like the transmission has gone out, Please let us know what happens.
Was this
answer
helpful?
Yes
No
Monday, September 26th, 2016 AT 2:50 PM

Please login or register to post a reply.

Sponsored links