No start, I recently just changed my oil pick up tube?

Tiny
LIONELL8732
  • MEMBER
  • 2008 PONTIAC GRAND PRIX
  • 5.3L
  • V8
  • 2WD
  • AUTOMATIC
  • 1,360,000 MILES
Hello, I recently just changed my oil pick up tube and dropped the pan. Cleaned it up and put fresh oil back in. Once I got everything back together. The car started and I heard some ticking, so I drove it two blocks over and the car completely shut off on me, so I literally had to push the car back home. Once it was home, I put the key in the ignition and the car will not start and I have all light power. Next morning, I took the battery to get tested and they say it was bad so I was like okay maybe this will fix the no start, so I pop that in and crossed my fingers. I literally got nothing, and I still have all light power. So, I went with my next conclusion which was the starter relay. Went and bought that and still no start. Please help.
Do you
have the same problem?
Yes
No
Saturday, November 26th, 2022 AT 11:50 AM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
I believe this is the one that the starter clicks. Is that correct? Are you planning to replace the engine, or do you want to try to fix the present one?

Let me know.

Joe
Was this
answer
helpful?
Yes
No
Saturday, November 26th, 2022 AT 10:19 PM
Tiny
LIONELL8732
  • MEMBER
I want to try and fix it. Help
Was this
answer
helpful?
Yes
No
Saturday, November 26th, 2022 AT 10:59 PM
Tiny
LIONELL8732
  • MEMBER
What will I need to do?
Was this
answer
helpful?
Yes
No
-1
Saturday, November 26th, 2022 AT 10:59 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

I'm getting confused between two different threads with the same issue with different users. Am I correct this is the same person that I was speaking with prior, Lavell 11?

If it is, let's focus on the original post. If it isn't let me know.

Joe
Was this
answer
helpful?
Yes
No
Sunday, November 27th, 2022 AT 12:12 AM

Please login or register to post a reply.

Sponsored links