Fuel pump relay

Tiny
SHARPFISHERMAN
  • MEMBER
  • 2001 MITSUBISHI GALANT
  • 3.0L
  • V6
  • FWD
  • AUTOMATIC
  • 225,000 MILES
I got a 2001 Mitsubishi galant that I can't get to start. I got in the car to start it and it started for about 2 sec and then died and won't start back. The fuel pump is not kicking on so I took it out and hook it up directly and it worked so I changed filter and put back in and again it would not work. So I changed the fuel pump relay and still wouldn't work. So I took the old pump back out and hooked up a new fuel pump, and again it did not work. I checked to see if there was power to the relay and I got nothing with the key off and the key on. So my question is, what would cause there to be no power to both the fuel pump and the relay. And it does have the anti theft system equipped.
Do you
have the same problem?
Yes
No
Monday, February 23rd, 2015 AT 12:10 AM

46 Replies

Tiny
WRENCHTECH
  • EXPERT
Hello,

There is a fuse #13 that needs to be checked which powers the relay here is a guide to help us get started and the fuel pump and engine wiring diagrams so you can see how the system works.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Check out the diagrams (Below). Please let us know what happens.

Cheers

Was this
answer
helpful?
Yes
No
+1
Monday, February 23rd, 2015 AT 2:10 AM
Tiny
SHARPFISHERMAN
  • MEMBER
Ok test light comes on at fuel pump and fuel pump relay with key on. But still fuel pump is not kicking on.
Was this
answer
helpful?
Yes
No
-1
Friday, February 27th, 2015 AT 9:47 AM
Tiny
WRENCHTECH
  • EXPERT
Power at the fuel pump? Are you sure about that?

It's only supposed to power for the first 2 seconds when the key is first turned on.
Was this
answer
helpful?
Yes
No
+2
Friday, February 27th, 2015 AT 1:26 PM
Tiny
SHARPFISHERMAN
  • MEMBER
No am not really for sure cause I didn't know where to really touch the test light at thE fuel pum. So I touch it in the wire harness and the fuel pump and the test light come on in like 2 or 4 wires back there with the key on. But not for sure if that was right
Was this
answer
helpful?
Yes
No
Friday, February 27th, 2015 AT 5:39 PM
Tiny
WRENCHTECH
  • EXPERT
If you're having trouble working a test light, then we don't have much chance of solving this.

It looks like both the power wire and the ground wire are black.

https://www.2carpros.com/images/external/87613534.gif
Was this
answer
helpful?
Yes
No
+3
Friday, February 27th, 2015 AT 6:09 PM
Tiny
LAMSHA
  • MEMBER
  • 2000 MITSUBISHI GALANT
I have a 2000 Mitsubishi galant 6cyl im trying to replace a fuel pump relay and im trying to identify which it is because I see more than one of those

We know where the fuse box is for the fuel pump relay just trying to find which one is it because the plugins look alike
Was this
answer
helpful?
Yes
No
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
SATURNTECH9
  • EXPERT
While cranking see if you have power to both sides of the fuel pump fuse if you do the relay is working.
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
KHLOW2008
  • EXPERT
Refer to diagram.
Was this
answer
helpful?
Yes
No
+1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
LAMSHA
  • MEMBER
Thanks alot for diagram and the connectors to the fuel pump one of its prong has a burnt mark on it what could that possibly be
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
SATURNTECH9
  • EXPERT
One of the terminals to the fuel pump module is burnt?If so probably a bad fuel pump. Do you have power and ground to the fuel pump while cranking the engine?
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
LAMSHA
  • MEMBER
Yes it does have power
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
SATURNTECH9
  • EXPERT
If there is power and ground to the fuel pump and its not working bad fuel pump.
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
EBERTJOEL
  • MEMBER
  • 2003 MITSUBISHI GALANT
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 220,000 MILES
I have a 2003 Mitsubishi Galant that will not start. It has spark so I looked for fuel problems. There is no power going to the pump. I replaced the relay and still no power at the pump. I used a jumper wire instead of the relay and the pump turns on but the car sill will not start. Why wouldn't power be going tot he fuel pump relay to activate it?
Was this
answer
helpful?
Yes
No
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
See diagram below
Was this
answer
helpful?
Yes
No
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
LAMSHA
  • MEMBER
Not sure but when I crank it up it acts as if it wants to start but it is not getting gas to start could it be the relay?
Was this
answer
helpful?
Yes
No
-2
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
EBERTJOEL
  • MEMBER
This diagram didn't help me. When the key is in the on position there is 12 volts at fuse 13, but the relay doesn't turn on. I tested the relay to be good.
Was this
answer
helpful?
Yes
No
+3
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
SATURNTECH9
  • EXPERT
If you getting power and ground at the fuel pump module at the gas tank the relay is working.
Was this
answer
helpful?
Yes
No
-1
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Check and test the violet wire on the relay to the computer controlled circuit could be open
Was this
answer
helpful?
Yes
No
+2
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
LAMSHA
  • MEMBER
How do you check for the power and ground to the fuel pump module
Was this
answer
helpful?
Yes
No
Monday, October 29th, 2018 AT 12:15 PM (Merged)
Tiny
EBERTJOEL
  • MEMBER
Ok, yes relay 2 (the top one) does not have a complete circuit, to what I assume is due to the computer leaving it open due to some other condition? I tested the ECU, something I read said to test the MAP sensor plug for 5 volts when the car is in the 'on' position to see if the ECU is working, it did so it should be working? Something else I read said it could be a bad crankshaft censor, I tested the ohms on the censor and I got 4 M ohms between 2 of the 3 connections and 0 between the others. Is this censor bad? If this censor was bad would it keep the fuel pump relay circuit open? If it was bad would I still have spark when I turned the car over?
Was this
answer
helpful?
Yes
No
+3
Monday, October 29th, 2018 AT 12:15 PM (Merged)

Please login or register to post a reply.

Recommended Guides