Brake lights not working

Tiny
RODCHERO86
  • MEMBER
  • 2004 MINI COOPER
  • 1.6L
  • 4 CYL
  • 2WD
  • MANUAL
  • 153,000 MILES
I have no brake lights. I've changed the switch twice now still no luck. I have 12v going into switch, the ground is good the other 2 wires have 1.3v coming out when you apply the brakes. Any ideas? Thanks
Do you
have the same problem?
Yes
No
Friday, May 7th, 2021 AT 1:31 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

The low voltage may be because it is sending to a module. Do me a favor. I need a production date to get into the correct schematics. If you look at pic 1, it shows the options. Let me know which I should focus on.

Take care,

Joe
Was this
answer
helpful?
Yes
No
Friday, May 7th, 2021 AT 9:12 PM
Tiny
RODCHERO86
  • MEMBER
Hello, it's a 10/03. I do have Haynes manual but it's very vague. I peeled back the carpet to get access to the body unit also there is some moisture on the floor. Thanks
Was this
answer
helpful?
Yes
No
Saturday, May 8th, 2021 AT 5:58 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi,

If there is moisture, make sure the connection isn't corroded. Also, when you put it back together, make sure to use dielectric grease on the connection. That will help prevent issues with the connection and corrosion.

I looked up the schematic of the brake light switch based on the production date. It is attached below. It is very vague.

Let me know.

Joe

See pic below.
Was this
answer
helpful?
Yes
No
Saturday, May 8th, 2021 AT 7:39 PM

Please login or register to post a reply.

Sponsored links