No air is blowing from vents (hear a noise in the rear of the car)

Tiny
SHAWNTIAC
  • MEMBER
  • 2009 MERCEDES BENZ ML350
  • 3.5L
  • 4WD
  • AUTOMATIC
  • 76,232 MILES
The heat has been working fine. The car was washed yesterday morning and during the afternoon the heat was working. I attempted to drive vehicle later yesterday evening and discovered the heat is not blowing any air out at all. Due to the cold temperatures is it possible something be frozen.
Do you
have the same problem?
Yes
No
Monday, January 6th, 2014 AT 5:02 AM

6 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Can you hear the blower motor running?
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 6:45 AM
Tiny
SHAWNTIAC
  • MEMBER
Jacobandnikolas, The heat is turned on a hear a noise from the rear of the vehicle. I am assuming the blower is trying to run. I never heard that noise. No air is blowing out not even the AC.
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 7:22 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Can you describe the noise?
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 7:36 AM
Tiny
SHAWNTIAC
  • MEMBER
It sounds quiet humming sound.
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 7:42 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I have to be honest, to the best of my knowledge, the blower motor is under the dash and not the rear. The sound you described can be many things. It could be a blower motor that is stuck and not spinning or it could even be the fuel pump you are hearing if it is in the rear.
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 7:52 AM
Tiny
SHAWNTIAC
  • MEMBER
Okay, thank you!
Was this
answer
helpful?
Yes
No
Monday, January 6th, 2014 AT 8:01 AM

Please login or register to post a reply.

Recommended Guides