CAR MAKING NOISE WHEN MOVING

2007 Nissan Versa

Tiny

shenriquez84

May, 20, 2010 AT 9:35 AM

Noises problem
2007 Nissan Versa 4 cyl Front Wheel Drive Manual 98000 miles

I have a 2007 Nissan Versa with a 1.8L engine. Lately I have been getting a loud rattling noise coming from the engine when I reach 3,500rpm. The engine is also not accelerating as it was before, it takes much longer.
I have purchased new spark plugs, new air filters, and new belt. I will be installing these parts this weekend, but I just wanted to know if I needed to buy anything else.
I am not sure what is making this noise, and really want to get it fixed.

Thanks!

FOUND 1105 RELATED QUESTIONS

6 Answers

Tiny

mhpautos

May, 20, 2010 AT 10:02 AM

Hi there,

thank you for the donation,

I would be looking at the knock sensor first, a scan will pick up a faulty sensor and not all set fault codes will set the check light on, the noise may be engine ping as the knock sensor is not sending the signal to the ECU to alter the ignition timing, this swill also account foe the performance drop, start here,

mark (mhpautos)

Tiny

shenriquez84

May, 20, 2010 AT 10:48 AM

Thank you so much for your quick response!

I will check into this problem, but the only way to check it is to run a diagnostics with a scanner?

Thanks again

Tiny

mhpautos

May, 20, 2010 AT 5:47 PM

Hi there,

To make sure that this is the actual problem, yes. A scan will also show up any other unresolved fault codes as well.

Mark (mhpautos)

Tiny

shenriquez84

May, 22, 2010 AT 8:29 PM

Hi Mark,

I went to get a OBD II scan, and nothing was found. So I guess we can disregard the knock sensor.

By the way, today I also found the left side upper engine mount bushing cracked and somewhat broken. Do you know if this can be causing the rattling since at a higher rpm the engine shakes more?

Thank you so much for your help

Sebastian

Tiny

mhpautos

May, 22, 2010 AT 8:52 PM

Hi there,

If the noise in not constant and more with the transfer of weight due to acceleration and breaking, and it is more of a thump or crack, yes this could be the case, if the mount is as you say, replace it and see how it goes then, check all other mounts as well.

Mark (mhpautos)

Tiny

shenriquez84

May, 23, 2010 AT 6:34 PM

Hi Mark,

My apologies, I was not very clear in explaining the problem. So I went out to test drive the vehicle and check when the noise comes on.
I also forgot to mention that I have a 6 speed manual transmission on my 2007 Nissan Versa.

So, this repeats basically on any gear: Let's suppose I am driving at 40mphs on 4th gear and 2500-2600rpm. When I press the gas all the way in, then the car makes the noise and the car starts slowly picking up speed, until at about 3500-3700rpm, going at about 60mph. Then it stops making the noise.

That's probably as best as I can describe it. Again, I tested this on other gears (except 1st) and it happens on all.

My apologies for the unclear posts.

Sebastian

Please login or register to post a reply.

Windshield Wiper Blade Replacement Mercedes
Dynamat Door Installation
Brake Light Bulb Replacement Chevrolet
Door Panel Removal & Speaker Replacement
Wiper Blade Replacement Toyota Tacoma
Windshield Wiper Replacement Toyota Corolla