2001 Nissan Pathfinder poor acceleration

Tiny
CHRIS ANTU
  • MEMBER
  • 2001 NISSAN PATHFINDER
Engine problem
2001 Nissan Pathfinder V6 Two Wheel Drive Automatic 146743 miles

vehicle ran low on fuel, after fueling engine has poor acceleration, also would only run aprox 35mph. Started checking fuel system changed fuel filter since it had been awhile. And then engine wouln't accelerate when in park it sputters and cuts out now. Checked fuel pressure it had 2psi before the fuel rail & when reving fuel psi dropped to 1psi and engine dies. So I changed fuel pump and engine is still doing same thing. Also noticed on throttle body there is a sensor or some kind of relay that is clicking or unspooling when key is turned off could that be my problem? Any suggestions would be appreciated greatly
Do you
have the same problem?
Yes
No
Wednesday, December 5th, 2007 AT 7:32 PM

2 Replies

Tiny
E J PREWITT
  • MEMBER
HAVE YOUR MECHANIC CHECK THE AIR MASS AIR FLOW SENSOR
Was this
answer
helpful?
Yes
No
Wednesday, January 9th, 2008 AT 7:12 PM
Tiny
PATHFINDERDUDE
  • MEMBER
Ok the clicking is either the + battery terminal loose, or a relay is blown, or a fuse is blown. Check in the fuse box under steering wheel and see if fuel filter fuse is broken or solid and ok?
If fuse is ok, then got to figure out which power relay is busted or replace all of them, $10ea, or find some on ebay, online, or junk yard for cheap.

If still refuses to start, engine turns, check battery power, check alternator if that needs to be replaced, or starter coil/solenoid might be blown.

These are the only possible causes after you changed fuel pump and filter. That or someone stuck a banana in your muffler? LOL, this can do it also.
Was this
answer
helpful?
Yes
No
Saturday, April 5th, 2008 AT 4:59 AM

Please login or register to post a reply.

Recommended Guides