95 Grand Am 2.3L 117K miles, 5 speed

Tiny
REPOMANSAINTS
  • MEMBER
  • 1995 NISSAN
Awhile ago I was driving the car, it ran good and has lots of power, just recently it shut off on me, I went to start it and the starter just clicked, so I figured the starter was out so I replaced it, it did the same, nothing, I towed it home and checked it out, I manually turned the crank pully, and heard a loud noise and felt the engine get unstuck or something, then I went to turn the car on and it did turn on but theres a loud bang while its running, I had a friend come over thats a master tech at nissan/gm and he told me it was the rod bearings, so I tore apart the bottom(oil pan) and he checked the rod bearing and he said they are fine then that it was the valves, I took the head off and it looked good, when putting back together I bent a couple of valves, I put a brand new head on, I turned it on and runs fine except aloud bang, then they told me its the timing chain that it had stretched and that its banging on the housing, replaced timing chain and sprockets and still nothing, I can turn the car on and turns on right away but theres a loud bang, don't know what else to do but to replace the engine, probably would of been cheaper by now, I would normally throw the car away but its a very nice car, what else could be the problem
Do you
have the same problem?
Yes
No
Sunday, February 18th, 2007 AT 8:12 PM

2 Replies

Tiny
REPOMANSAINTS
  • MEMBER
Bump
Was this
answer
helpful?
Yes
No
Monday, March 5th, 2007 AT 1:32 AM
Tiny
REPOMANSAINTS
  • MEMBER
Happy easter
Was this
answer
helpful?
Yes
No
Sunday, April 8th, 2007 AT 2:53 PM

Please login or register to post a reply.

Recommended Guides