1997 Hardbody Brake Problem

Tiny
FRANKNT
  • MEMBER
  • 1997 NISSAN FRONTIER
I have a 1997 Hardbody XE 4wd, 4cyl, 5spd, standard cab. The brake pedal goes to the floor only while the engine is running, as soon as I turn the engine off, it is firm again. What could this be?
Do you
have the same problem?
Yes
No
Friday, November 30th, 2007 AT 12:09 PM

3 Replies

Tiny
MERLIN2021
  • EXPERT
Perform this test Shut engine off, opump brake pedal until the air in the booster is gone. Then hold pressure on it for a minute, Does the pedal sink? Have you checked the fluid level in the master cylinder? Is the brake fluid contaminated with oil or tranny fluid? Take a little bit out of the reservoir, and add it to a cup with water in it, swirl, any oil float to the top? Get back with these answers!
Was this
answer
helpful?
Yes
No
Friday, November 30th, 2007 AT 12:41 PM
Tiny
FRANKNT
  • MEMBER
Ok I shut off the engine and pumped the brakes until the air was gone and held it down for a minute. The Pedal stayed in the same position.
The fluid is a brownish color and is at its normal level. I took some out and put in a cup with some water and it became milky but no oil.
Was this
answer
helpful?
Yes
No
Friday, November 30th, 2007 AT 1:19 PM
Tiny
MERLIN2021
  • EXPERT
No leaks? Fluid level full? Is ABS light on? ANY recent brake work? I have seen this if the pads are not properly seated in the slide area.
Was this
answer
helpful?
Yes
No
Friday, November 30th, 2007 AT 1:24 PM

Please login or register to post a reply.

Sponsored links