93Altima Idle/Running Problems

Tiny
JS1321
  • 1993 NISSAN ALTIMA

I have a 1993 Nissan Altima GXE with 112,000 original miles on it. This car starts up perfectly and runs like nissan's do, purs like a kitten, but then, after about 15 minutes of running, it starts to back-up and act like it's flooding out or something, shaking and spitting and spuddering, and then wont run. Let it sit awhile, or the next day. Starts right up, runs great for 10-15 minutes, then dies out spitting and spuddering again. Is it possible this could be my fuel pump, or do fuel pumps just flat go out?The car has brand new Plugs, Plug Wires, Cap & Rotor, Air Cleaner, & Fuel Filter. Other than that, the car sounds sweet. This is driving me crazy and I really need this car.

Do you
have the same problem?
Yes
No
Friday, January 26th, 2007 AT 12:43 PM

3 Replies

Tiny
JACK42
  • MEMBER

IS the check engine light on? Might need a scan of the PCm to give us an idea of where to start

Was this
answer
helpful?
Yes
No
Friday, January 26th, 2007 AT 2:46 PM
Tiny
JS1321
  • MEMBER

The check engine light only comes on at the exact time when it dies

Was this
answer
helpful?
Yes
No
Friday, January 26th, 2007 AT 2:50 PM
Tiny
JACK42
  • MEMBER

When it dies you need to check for spark and fuel pressure to see which one is the problem. Might want to have it scanned to see if it stored a code

Was this
answer
helpful?
Yes
No
Saturday, January 27th, 2007 AT 7:31 AM

Please login or register to post a reply.

Other Fuel System Pump Noise Questions