1993 Nissan Altima Gas pedal stopped working

Tiny
HOLSEN
  • MEMBER
  • 1993 NISSAN ALTIMA
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 140,000 MILES
I was driving on the freeway when I felt my gas pedal give out. I have had the throttle cables slip off before so I checked that, but they were still attached. When I pulled the cables the engine did not reve up at all. What is the problem?
Do you
have the same problem?
Yes
No
Thursday, August 13th, 2009 AT 9:42 AM

2 Replies

Tiny
AAP34798
  • MEMBER
The linkage that you are seeing me point to is affixed by just popping the "ball ends" by pressure. same as wiper linkage and can get loose with age and likely popped off.
you'll notice, mine has already done this and i've pushed the top ball back on a couple of times, but, has gotten too loose to continue.
notice that i used "metal wire, fishing swivels" to hold mine together in a bind(worked just fine).
go to a junk yard and just steal another.
by the way, it was fun when it happened while i was going into a turn and almost got smashed up. . .oh, that rod is connected below to the throttle body and which is why the car will idle fine without being connected but will not have a pedal.


http://www.2carpros.com/forum/automotive_pictures/400521_082409_19131_1.jpg



http://www.2carpros.com/forum/automotive_pictures/400521_082409_19141_2.jpg



http://www.2carpros.com/forum/automotive_pictures/400521_082409_19111_1.jpg


http://www.2carpros.com/forum/automotive_pictures/400521_090109_16011_1.jpg



http://www.2carpros.com/forum/automotive_pictures/400521_090109_16021_1.jpg

Was this
answer
helpful?
Yes
No
+1
Monday, August 24th, 2009 AT 10:48 PM
Tiny
SCOTTFROMSCOTLAND
  • MEMBER
Hi what is this part called and where can I buy it?
Was this
answer
helpful?
Yes
No
+2
Friday, February 21st, 2014 AT 12:45 AM

Please login or register to post a reply.

Recommended Guides