1997 Mitsubishi Eclipse Shifting


Transmission problem
1997 Mitsubishi Eclipse 4 cyl All Wheel Drive Automatic 102, 00 miles

Can I reboot my cars computer to make the transmission shift propperly? If so How?

The car starts off ok, but it won't go out of second gear. The Rpm's stay at about 4-5 at about 60mph.
I also noticed that in cooler weather it would shift out of that gear but once the car was run for a couple of miles (highway) and then stopped it would not want to shift out of that gear.

I had my transmission replaced a year ago and when I got the car back the company that replaced the Transmission said that it would shift fine when hooked up to their computers and shifted manually. When they took it off off their equipment it wouldn't shift propperly and told me that they had a error message for only the dealer could read. So I talked to some friends and they said that if I could reboot the cars computer it would probably fix the problem.

Do you
have the same problem?
Monday, December 1st, 2008 AT 10:02 AM

1 Reply


Posted at Wed Jan 21, 2009 8:04 pm
By tharge86, New to the forum
Give Feedback | Votes: 0

Transmission problem
1998 Mitsubishi Eclipse 4 cyl Front Wheel Drive Automatic 102000 miles

I am having a huge issue with my 98 eclipse GST.
I have been having this problem for a while now and I have had it looked at by a trans mechanic/electrical specialist/mechanic.
To start, when I shift into any gear, (automatic) whether it is reverse, drive, or any low gear, it feels like the engine or trans. Kicks hard into gear. Only when I shift into a gear, not into neutral or park.
When I start to move, with it in drive, the car with rev all of the way up to 6000 rpms if I step on the gas hard and then its slams into the next gear. ( This is when overdrive is off.) If I lightly press the gas, the rpms with go up normal but then, once again, slam into the next gear. The symptoms are worse when overdrive is on, but may not even shift at all (always with a slam) into the next gear. I can get up to any speed that I wish by doing this: I will turn off overdrive, accelerate quickly; when the rpms get around 5000, I let off the gas, the rpms drop to 1500-2000 and it lightly kicks into the next gear or may even totally skip over 2nd right into 3rd.I'm not quite sure which gear. Another problem is that when I reach this gear.I push the gas to accelerate (intending for the trans to kick into a lower gear) it kicks out of the gear I was in, but acts as if I am in neutral. But then when it is at a high rpm (5000-6000) it will slam and I let off the gas for it only to kick back into the gear it was in from the start. I recently had the engine computer replaced due to it sending the qrong voltage to the trans computer. This fixed the problem for a short period of time (about 3 weeks) but only came back worse than before.
This is very frusterating and I would like to upgrade my turbo/blow-off valve/body. But I need to fix this first.
If you can be of ANY help, that would be AWESOME!

Was this
Monday, January 26th, 2009 AT 10:18 AM

Please login or register to post a reply.

Recommended Guides