POWER DOOR LOCKS

1997 Mercury Villager

Tiny

mmd

December, 14, 2008 AT 6:13 PM

Electrical problem
1997 Mercury Villager 6 cyl Front Wheel Drive Automatic 100, 00 miles

We do not have remote entry. When I press the lock or unlock button on either door, the two front door locks may not respond or they will respond very sluggishly, that is they will make a rattling sound for a second or two then respond. The side door and rear hatch work fine. Also, if I excercise the locks, lock, unlock, lock, unlock 8 or 10 times, the front doorlocks work fine for a short time. But after setting idle for 5 minutes, they are sluggish again.

3 Answers

Tiny

James W.

December, 14, 2008 AT 7:38 PM

Sounds like your door latches need to be lubed. You can liberally spray them down with silicone, lithium, or a graphite lube and work them a few times This should help. I don't recommend using WD40 or any kind of a rust breaker. This will become corrosive after time and make the problem worse. Hopr this helps.

Tiny

mmd

December, 14, 2008 AT 9:52 PM

You said to lube the door latches. What part do you mean. The doors open and close and latch just fine. Do you mean to remove the door panels and lube the door locks?

Tiny

James W.

December, 15, 2008 AT 7:49 AM

Yes, when you spray the latch in the end of the door, you will be lubing the lock mechanism at the same time. If, this doesn't work, you may have to pull the door panel, but I don't you'll have to.

Please login or register to post a reply.

Door Lock Replacement Toyota 4Runner
Door Panel Removal & Speaker Replacement